brut misbehaving - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-07-2013, 05:12 PM Thread Starter
sms
Established Member
 
sms's Avatar
 
Join Date: Feb 2013
Posts: 75
brut misbehaving

hi all just a quick one, my brut has misbehaved tonite, i turned the key and had a flashing dash, no starty, so i put my charger on left it for 10 mins, turned the key and only a click, however the dash has come back to life, left it for another fifteen mins and the bike fired up,now i dont have any head lights or indicators??

i hope its not a spu failure?

the bike seems to run ok, it seems to get hotter quicker than it normally does

any thoughts chaps?

2010 989r 6k on the clock

i await replies

sms

Last edited by sms; 06-07-2013 at 05:42 PM.
sms is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-07-2013, 05:22 PM
Senior Member
 
BrutaleHornet's Avatar
 
Join Date: Feb 2011
Location: The Netherlands
Posts: 639
Mmmmm, sounds like an SPU failure to me.
Check your fuses as well....

Good luck !!!

Cheers
BrutaleHornet is offline  
post #3 of 7 (permalink) Old 06-07-2013, 05:48 PM Thread Starter
sms
Established Member
 
sms's Avatar
 
Join Date: Feb 2013
Posts: 75
yeah will do, i was hoping ride it this sunday as haven't have bike long, just over 3 month, so just out of dealer warranty, surprise!

ill check it tomorrow and report back, if not the hunt for a new one begins

thanks

sms
sms is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-07-2013, 07:07 PM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Sounds like a weak battery at first then possibly a fuse. Do the later Brutales have the same SPU issues? I thought that was sorted.
CAG is offline  
post #5 of 7 (permalink) Old 06-08-2013, 03:28 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
I don't think so Carl, I imagine it's a failed battery. Or a bad connection maybe.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #6 of 7 (permalink) Old 06-10-2013, 05:09 AM Thread Starter
sms
Established Member
 
sms's Avatar
 
Join Date: Feb 2013
Posts: 75
Quote:
Originally Posted by Donsy View Post
I don't think so Carl, I imagine it's a failed battery. Or a bad connection maybe.

spot on dead battery, thanks for the help chaps, brut rides again

sms
sms is offline  
post #7 of 7 (permalink) Old 06-10-2013, 08:07 AM
Senior Member
 
Red Baron's Avatar
 
Join Date: Sep 2012
Location: San Diego, north county
Posts: 1,150
Red Baron is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome