Brutale 750 - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-21-2013, 04:08 AM Thread Starter
New Member
 
Join Date: Nov 2008
Posts: 5
Angry Brutale 750

Need help again down here in Thailand , my 750 Brutale has been unused for 6 months , it started first time and I left it ticking over to warm up , when I went to rev it up it just wouldn't rev and stalled , I removed all fuel cleaned the tank and used fuel injection cleaner , replaced the plugs , when I took the air filter out the foam inside just fell apart , I have replaced but still have the same problem it will not rev !!! Any suggestions ?
SENNA is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-21-2013, 06:25 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
When you cleaned the tank, did you remove it from the bike? It sounds like a fuel starvation issue. This would be caused by a clogged fuel filter. You changed the fuel filter and made sure the lines in the tank haven't turned to junk, right?
CAG is offline  
post #3 of 5 (permalink) Old 05-21-2013, 08:46 PM Thread Starter
New Member
 
Join Date: Nov 2008
Posts: 5
Quote:
Originally Posted by CAG View Post
When you cleaned the tank, did you remove it from the bike? It sounds like a fuel starvation issue. This would be caused by a clogged fuel filter. You changed the fuel filter and made sure the lines in the tank haven't turned to junk, right?
Thanks for taking the time to give me your input , no I had not done that , have now replaced the fuel filter and the lines in the tank which where full of gunge and it now runs perfectly . Thanks again your help much appreciated .
SENNA is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-21-2013, 09:48 PM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Easy fix. I'm glad you are up and running.

Ride safely!
CAG is offline  
post #5 of 5 (permalink) Old 05-24-2013, 12:54 PM
New Member
 
Join Date: Mar 2012
Location: Reno
Posts: 21
The gasohol in Thailand is pretty bad, my buddy with an SP2 in Bangkok just had this same issue.
Glenns is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome