1078 fuel tank vent valve? - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-12-2011, 11:06 AM Thread Starter
New Member
 
daves1078rr's Avatar
 
Join Date: Sep 2011
Location: Madison, WI
Posts: 44
1078 fuel tank vent valve?

I'm thinking mine is plugged or broken. I downloaded a parts manual but cant seem to find it to test.
Anybody have a picture or exact location/test procedures?

My tank wont vent and after riding the tank has very high vacuum in it.
I used high pressure air in the rear most hole with the black seal that mates up to the gas cap and air passed through, albeit not easily. I also pushed air backwards through the little hole in the cap and it blew out the seal in the cap!
Cap blockage? Or just too much pressure in the hose!

'09 Brutale 1078RR. Full Arrow exhaust, damper. Lots of carbon fiber bits! Sold
'12 ZX14R
daves1078rr is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-12-2011, 12:03 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,120
Send a message via Skype™ to esq'z me
Maybe too much air pressure. What was line psi? 90~120? tank vent should pass air blown from your mouth easily....maybe 5 psi? It doesn't have to flow a lot of air.

There is a fuel separator labyrinth in the cap, the seal mates the cap to the internal hose in the tank that goes to your evap can.

Do a search on eliminating the evap system (your bike has same system as mine did). Pretty simple job, will provide a little bit more gas capacity in the tank, remove a little bit of weight, and eliminate a potential problem (overfilled tank resulting in contaminated canister).

DO NOT buy the TPO evap emissions system eliminator kit on eBay.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #3 of 3 (permalink) Old 10-12-2011, 02:21 PM Thread Starter
New Member
 
daves1078rr's Avatar
 
Join Date: Sep 2011
Location: Madison, WI
Posts: 44
Yep! Line pressure was 110 but I only gave the little black seal on the tank a short little blast. Tiny blast popped the seal on the cap though!
I'll look for the evap removal thread!

edit: found it! evap canister removal

Guess I need to order a new pump O ring and some vac caps!

'09 Brutale 1078RR. Full Arrow exhaust, damper. Lots of carbon fiber bits! Sold
'12 ZX14R

Last edited by daves1078rr; 10-12-2011 at 02:34 PM.
daves1078rr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome