990R engine cuts out dangerously under braking sometimes .. - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 29 (permalink) Old 05-17-2011, 12:00 PM Thread Starter
New Member
 
BlackNinja's Avatar
 
Join Date: Aug 2010
Location: Jersey, Channel Islands
Posts: 69
990R engine cuts out dangerously under braking sometimes ..

Entered a roundabout after being hard on the brakes with clutch in for the last part as I dropped down a few gears and ready to engage again ... leaned the bike whilst engaging clutch and no drive, nearly fell off! The engine had stopped ... started it again with the starter and I was away bloody sharpish as there was a lorry aimed right at me ffs! Similar thing happened when changing gear a bit slowly going down hill through a slight bend at quite slow speed with not a lot of braking on that occasion, the rear locked and swung round a bit, pulled the clutch, hit the starter and away again. Dangerous ...!!

2010 Brutale 990R

Last edited by BlackNinja; 05-17-2011 at 12:06 PM.
BlackNinja is offline  
Sponsored Links
Advertisement
 
post #2 of 29 (permalink) Old 05-17-2011, 01:30 PM
Senior Member
 
zvez's Avatar
 
Join Date: Feb 2007
Location: georgia
Posts: 1,115
Have the valves been checked? It could be a tight valve

Chris

Chris
2014 B3 Brutale 800
That's Giuliano Maoggi and the start of the 1956 Motogiro d'Italia.
zvez is offline  
post #3 of 29 (permalink) Old 05-17-2011, 02:12 PM
Established Member
 
joanne's Avatar
 
Join Date: Feb 2008
Location: england
Posts: 215
Send a message via Yahoo to joanne
check out my thread, i have had a right game with my 990r that's how mine started, now the engine has gone completely. same thing when slowing down , drop[ed agear a had no gears them slurred to a halt. they reckon it was the return spring and replaced it for a upgraded part but it was to late engine beyond repair. get it to shop and don't rest untill they change the spring! or fix the whole thing, i'v been mucking about now for just over two months.

good luck.

It's all very funny until someone gets hurt, then it's hilarious.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
joanne is offline  
Sponsored Links
Advertisement
 
post #4 of 29 (permalink) Old 05-17-2011, 03:23 PM
Senior Member
 
billywhizzz's Avatar
 
Join Date: Dec 2010
Location: Barnsley, UK
Posts: 405
Quote:
Originally Posted by BlackNinja View Post
Similar thing happened when changing gear a bit slowly going down hill through a slight bend at quite slow speed with not a lot of braking on that occasion
My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.

K1300R
Diavel
Pushbike
billywhizzz is offline  
post #5 of 29 (permalink) Old 05-17-2011, 04:18 PM Thread Starter
New Member
 
BlackNinja's Avatar
 
Join Date: Aug 2010
Location: Jersey, Channel Islands
Posts: 69
Quote:
Originally Posted by billywhizzz View Post
My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.
My first thought was fuel starvation as it has happened a couple of times whilst running in on low fuel braking for a junction square on ... but the time entering the roundabout was with 1/2 a tank of juice!

2010 Brutale 990R
BlackNinja is offline  
post #6 of 29 (permalink) Old 05-17-2011, 04:21 PM Thread Starter
New Member
 
BlackNinja's Avatar
 
Join Date: Aug 2010
Location: Jersey, Channel Islands
Posts: 69
Quote:
Originally Posted by joanne View Post
check out my thread, i have had a right game with my 990r that's how mine started, now the engine has gone completely. same thing when slowing down , drop[ed agear a had no gears them slurred to a halt. they reckon it was the return spring and replaced it for a upgraded part but it was to late engine beyond repair. get it to shop and don't rest untill they change the spring! or fix the whole thing, i'v been mucking about now for just over two months.

good luck.
Hi, looked at the thread and this is a different problem. My bikes already been with the dealer for near on 3 months mainly due to not getting the parts quick enough which eventually ended with a new set of instruments after 650 miles so don't want that again now I have it back!

2010 Brutale 990R
BlackNinja is offline  
post #7 of 29 (permalink) Old 05-17-2011, 06:50 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Exclamation -10

Quote:
Originally Posted by billywhizzz View Post
My 1090 has done this a couple of times, cut out when changing down, into a corner, braking hard, makes me wonder if its the tilt sensor....but only a guess.
Not the tilt sensor, not even sure the 1090's have one ?

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #8 of 29 (permalink) Old 05-18-2011, 12:41 AM
Established Member
 
joanne's Avatar
 
Join Date: Feb 2008
Location: england
Posts: 215
Send a message via Yahoo to joanne
they do love to hang to them don't they.

I mean we by them to ride them not have them sit around the work shop.
But when i ordered after market parts, hugger, frame protectors, there in two days. mmmmmmm! something wrong some where.

It's all very funny until someone gets hurt, then it's hilarious.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
joanne is offline  
post #9 of 29 (permalink) Old 05-18-2011, 01:39 AM
Senior Member
 
eddypro's Avatar
 
Join Date: Feb 2011
Location: brisbane
Posts: 3,493
buy a powercommander,this will sort it out,mine used to do the same thing but on a 1078,very Dangerous.throttle response is fantastic now.has not stalled once.
eddypro is offline  
post #10 of 29 (permalink) Old 05-18-2011, 01:52 AM
Senior Member
 
Totale's Avatar
 
Join Date: Aug 2009
Location: Land of the Black Prince
Posts: 851
eddy - just fitting a PC won't sort a euro3 low rpm problem - Balancing throttle bodies set CO and TPS will...
Totale is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome