1090RR Barracuda Mirrors - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 05-11-2011, 12:21 PM Thread Starter
New Member
 
Join Date: Aug 2010
Posts: 25
1090RR Barracuda Mirrors

My stock mirrors just began falling apart (really the mirror fell out while riding) so I decided to try mounting the Barracuda mirrors with integrated signals. I was able to drill and tap the existing bar mounts to fit the 10mm stems of the Barracuda mirrors and it all looks really nice (I'll post some pics). Only problem is I get no turn signal lights when I wire them up. I tested the old signals just to make sure I hadn't popped a fuse or relay and sure enough they work fine. Does anyone know the proper resistance needed? I guess I'll try testing the old signals with a meter and see if there's a major difference. Any advice? Thanks!
slyfox is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-11-2011, 03:08 PM
Senior Member
 
billywhizzz's Avatar
 
Join Date: Dec 2010
Location: Barnsley, UK
Posts: 405
They should light up without a resistor, so assuming they are LED's ?? they are probably wired up the wrong way which means they won't light up at all. To get the flash rate you may need to add resistors, I fitted some LEDs to my 1090, no resistor flashed very fast, 1 x 23 ohm resistor flashed ok but after a while they would stop flashing until the ignition was turned off and and on again. Finally I fitted 2 x 23 ohm resistors per side and all is good, it all depends on what current draw the Barracudas have.

K1300R
Diavel
Pushbike
billywhizzz is offline  
post #3 of 15 (permalink) Old 05-11-2011, 04:46 PM
Senior Member
 
Join Date: Oct 2010
Posts: 456
post up some pics on what this looks like.
roadbiking is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 05-13-2011, 03:44 PM Thread Starter
New Member
 
Join Date: Aug 2010
Posts: 25
Billywhizzz. Thanks I was thinking it might be the resistance issue. I just wrongly assumed that replacing led lights with led lights would work! When I connect up the barracudas (tried both ways) I get one quick flash from the tail lights then I have to reset the ignition to get anything to work. I guess I'll try a few resistors and see what happens. I can't seem to find any info on the barracudas so I guess it will be trial and error. Thanks again for all the feedback. I'll post some pics up as soon as I get them working! These are the mirrors
http://www.barracudamoto.it/en/shop/street-indicator/
slyfox is offline  
post #5 of 15 (permalink) Old 05-14-2011, 03:05 AM
Senior Member
 
billywhizzz's Avatar
 
Join Date: Dec 2010
Location: Barnsley, UK
Posts: 405
Quote:
Originally Posted by slyfox View Post
Billywhizzz. TI'll post some pics up as soon as I get them working! These are the mirrors
http://www.barracudamoto.it/en/shop/street-indicator/
Will be interested in how they perform compared to the standard mirrors, they look good.

K1300R
Diavel
Pushbike
billywhizzz is offline  
post #6 of 15 (permalink) Old 05-24-2011, 09:25 PM Thread Starter
New Member
 
Join Date: Aug 2010
Posts: 25
Well this has turned out to be a major PITA. I added one 10-watt/10-Ohm resistor to front and tested and still got only one flash in the rear and then nothing until an ignition reset. Added a second 10-watt/10-Ohm resistor and now get a steady flash in the front and rear but the front is only about half brightness. I thought that perhaps balancing out the resistors between the front and rear would fix that but no go. I guess its time to start looking for a new flasher relay that might actually work.
slyfox is offline  
post #7 of 15 (permalink) Old 05-25-2011, 02:48 PM
Senior Member
 
billywhizzz's Avatar
 
Join Date: Dec 2010
Location: Barnsley, UK
Posts: 405
How have you connected the resistors, is series or in a parallel? Should be in parallel, for the LEDs fitted to mine had to use 2 x 23 ohms resistors per front indicator.

K1300R
Diavel
Pushbike
billywhizzz is offline  
post #8 of 15 (permalink) Old 05-25-2011, 04:28 PM
Established Member
 
Join Date: Apr 2011
Posts: 207
Slyfox My Left Mirror Fell Out Also. That Should Be A Factory Covered Problem. The Dam Thing Cost Almost Two Bills, That Sucks. Not Sure About Thos Italians.
modobigdog is offline  
post #9 of 15 (permalink) Old 05-25-2011, 04:34 PM
Established Member
 
Join Date: Apr 2011
Posts: 207
Thumbs down 1090rr Mirrors

WHATS THE STORY WIYH THE MIRRORS? THIS IS THE THRID TIME I HERD OF THIS. AND IT HAPPENED TO ME ALSO. TWO BILLS FOR ONE MIRROR
modobigdog is offline  
post #10 of 15 (permalink) Old 05-25-2011, 09:01 PM
Established Member
 
Join Date: Apr 2011
Posts: 207
Talking barracuda mirrors

are the barracuda mirrors better than the stock ones? it sounds like a hassel to put them on.
modobigdog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome