Need help - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-05-2010, 12:11 PM Thread Starter
Senior Member
 
bartolim's Avatar
 
Join Date: Jul 2005
Location: New Port Richey FL
Posts: 446
Need help

OK, I've talked about this before, but still can't figure it out. 2005 Brutale 750S. Bike starts, idles ok, but once you try to give it throttle, it dies. I thought it might be the fuel pump/filter, exchanged it for the one in my F4, ran perfect, took it out for a 30 min ride. Tried to take it out the next day and no luck. The TPS is at 1.7, checked it with the VDSTS software. Plugs are good, air filter clean.
bartolim is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-06-2010, 02:40 AM
Senior Member
 
Join Date: Aug 2009
Posts: 605
fuel line or injector air leak? i'm not an expert just a stab in the dark
dingodog is offline  
post #3 of 5 (permalink) Old 08-06-2010, 05:27 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Did you put the fuel pump back in the F4 to see if it works in that bike?
When you say to tried to take it out the next day, did you get the same symptoms (idle but would die with throttle?)
CAG is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-06-2010, 01:29 PM Thread Starter
Senior Member
 
bartolim's Avatar
 
Join Date: Jul 2005
Location: New Port Richey FL
Posts: 446
I tried both pumps, they worked in the F4 not the Brutale, and yes same symptoms. The thing that has me puzzled, is that when I first installed the new pump and filter in the Brutale it worked fine.
bartolim is offline  
post #5 of 5 (permalink) Old 08-06-2010, 01:35 PM
Senior Member
 
pierre.poilane's Avatar
 
Join Date: Jul 2008
Location: San Francisco, CA
Posts: 308
New Site Garage
Bad contacts in the kill switch? I read a while back of somebody who took one apart to investigate the source of stalling and that quality of that assembly was really sub-par.
pierre.poilane is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome