Swingarm Discoloration New 990R - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 08-03-2010, 04:47 PM Thread Starter
New Member
 
Brutalian's Avatar
 
Join Date: Jul 2010
Posts: 28
Swingarm Discoloration New 990R

Just got my 2010 990R last week, and it came from the dealer with the weirdest looking swingarm. It has turned purple and has black spots. I asked my dealer what it was, and they have no answers. I thought it was just oil or grease on the surface when I picked it up, so I did not worry about it. Then when I got it home and was ready to wipe off the grease, I realized it was the black anodizing, and that the entire swingarm was fading around the areas of black. Looks like hell for a new 15K bike. I would love to know if anyone else has seen this problem on the new 2010 bikes. Go here for a photo:
http://yfrog.com/i3img5124ej

Last edited by Brutalian; 08-03-2010 at 05:24 PM.
Brutalian is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 08-03-2010, 04:53 PM
Senior Member
 
MihaSLO's Avatar
 
Join Date: Jul 2007
Location: Ljubljana, Slovenia, Europe
Posts: 1,661
Any pictures? The color on those bikes that have matt finish is pretty hard to maintain in original state.
MihaSLO is offline  
post #3 of 16 (permalink) Old 08-03-2010, 06:03 PM
Senior Member
 
jeffk's Avatar
 
Join Date: May 2010
Location: Long Valley, NJ
Posts: 324
that's strange and I could see how you would think it was just dirt/oil. Did you try cleaning it with anything?

------------------------------
The journey is the reward
Brutale 1090, Tiger 1050, Bonneville SE


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeffk is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 08-03-2010, 06:18 PM
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 2,316
New Site Garage
I'd immediately have Dealer contact MV Agusta ....that's simply wrong !

Tim
Current
MV Agusta Brutale 1090RR
MV Agusta Brutale 910R - Track Bike
Harley-Davidson Street Glide Rushmore
Harley-Davidson Road Glide Rushmore

Past
MV Agusta Brutale 1090RR
MV Agusta Brutale 990R LE Anniversary Edition #81/150
MV Agusta Brutale 750s
cruiser is online now  
post #5 of 16 (permalink) Old 08-03-2010, 10:15 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,118
Send a message via Skype™ to esq'z me
That is weird looking...I would be in contact with the dealer immediately...that ain't right.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is online now  
post #6 of 16 (permalink) Old 08-03-2010, 10:50 PM Thread Starter
New Member
 
Brutalian's Avatar
 
Join Date: Jul 2010
Posts: 28
Quote:
Originally Posted by jeffk View Post
that's strange and I could see how you would think it was just dirt/oil. Did you try cleaning it with anything?
Nothing I tried had the slightest effect on it. I started with mild bike polish and ended up using naptha which should remove any oils. It simply is not an oil on the surface, I think the swingarm was shipped from the factory with grease, fingerprints, etc. That grease must have protected the anodizing from UV or whatever faded the finish. I would not care if it were all purple or all black. Just one or the other! I spoke with the dealer service dept. today, and they said they used nothing harsh to clean it. I had the same problem with my radiator hose on my 2009 Brutale. It was purple and had an uneven look to it when I bought it from the same dealer.
Brutalian is offline  
post #7 of 16 (permalink) Old 08-04-2010, 01:42 AM
Senior Member
 
Totale's Avatar
 
Join Date: Aug 2009
Location: Land of the Black Prince
Posts: 851
ASAP get it in writing - as you said one or the other but not that
Totale is offline  
post #8 of 16 (permalink) Old 08-06-2010, 05:54 AM
Senior Member
 
Join Date: Sep 2009
Posts: 353
Brutalian, sorry to hear about your problem but were you able to get it resolved
Sarge is offline  
post #9 of 16 (permalink) Old 08-06-2010, 07:32 AM
Senior Member
 
cdamb's Avatar
 
Join Date: Feb 2006
Location: Not sure any more
Posts: 2,388
I had the same problem with my radiator hose on my 2009 Brutale. It was purple and had an uneven look to it when I bought it from the same dealer.[/QUOTE]

The same here and they replaced it for me at the 600 mile service.

B750 and B1078 RR both gone now.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"Twenty years from now you will be more disappointed by the things that you didn't do than by the ones you did do. So throw off the bowlines. Sail away from the safe harbor. Catch the trade winds in your sails. Explore. Dream. Discover."~Mark Twain
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cdamb is offline  
post #10 of 16 (permalink) Old 08-06-2010, 10:05 PM
Senior Member
 
slammp's Avatar
 
Join Date: May 2009
Location: Boston
Posts: 311
it also appears to be on the heel guard?
slammp is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome