Help, Brutale 910 won't start! - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-31-2010, 04:15 PM Thread Starter
New Member
 
Join Date: Apr 2009
Posts: 67
Help, Brutale 910 won't start!

Hey,
My brutale wont' start.. I don't hear the fuel pump prime. I just put in a new battery, and accidentally put the positive on the negative, and vis versa for a moemnt which caused a spark, then corrected it.. Now the pump won't prime..? Any ideas? Fuse might have blown? What should be my first steps and where are the fuses located?
Thanks a bunch guys
OutrageousCo is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-31-2010, 04:44 PM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Yes, you should have kept the F4 instead of flipping it.

Sounds like you fried the diode.
CAG is offline  
post #3 of 5 (permalink) Old 01-31-2010, 05:41 PM
Senior Member
 
fazer6's Avatar
 
Join Date: Mar 2006
Location: Tempe, AZ, USA
Posts: 8,920
Quote:
Originally Posted by CAG View Post

Sounds like you fried the diode.
yep, diode

B4 750S [sold]
B3 675R [waiting]
fazer6 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 01-31-2010, 07:34 PM Thread Starter
New Member
 
Join Date: Apr 2009
Posts: 67
Thanks for helping narrow it down..!! now what exactly is a diode and is it difficult to replace?
OutrageousCo is offline  
post #5 of 5 (permalink) Old 02-01-2010, 04:32 PM
New Member
 
Join Date: May 2009
Posts: 2
Quote:
Originally Posted by OutrageousCo View Post
Hey,
My brutale wont' start.. I don't hear the fuel pump prime. I just put in a new battery, and accidentally put the positive on the negative, and vis versa for a moemnt which caused a spark, then corrected it.. Now the pump won't prime..? Any ideas? Fuse might have blown? What should be my first steps and where are the fuses located?
Thanks a bunch guys
Hi,

Most likely the fuse under the rider seat is blown - its located next to the battery toward the rear light. There are two fuses, one is a spare.
Muenchhausen is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome