CPU error - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-21-2009, 07:59 AM Thread Starter
Established Member
 
russell910's Avatar
 
Join Date: May 2007
Posts: 125
Send a message via Yahoo to russell910
CPU error

Guys..

I have problem with my brutale 910 2007.

Headlamp and direction lamp is not working at all.

Bike can start and I can ride it normally but I noticed that the lamp is not turn-on even the high-lamp or pass lamp and direction lamp are not working.

I checked the fuses and clean the connectors.. but the problem still exist. So my guess is CPU damage.

Had anybody ever experience the same problem before?
My bike using 12 fuses. I found my friend's 750 using 13 fuses.

Anybody could recommend me where I can buy this brutale CPU?

Thanks a lot..
Attached Images
 
russell910 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-21-2009, 08:03 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
That is the SPU, not the CPU or ECU. It is available from the dealer or one of the forum sponsors that sells oem parts.
CAG is offline  
post #3 of 10 (permalink) Old 12-21-2009, 10:17 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
Quote:
Originally Posted by CAG View Post
That is the SPU, not the CPU or ECU. It is available from the dealer or one of the forum sponsors that sells oem parts.
And the new parts are updated for better reliability, too.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 01-30-2010, 11:15 PM Thread Starter
Established Member
 
russell910's Avatar
 
Join Date: May 2007
Posts: 125
Send a message via Yahoo to russell910
Quote:
Originally Posted by CAG View Post
That is the SPU, not the CPU or ECU. It is available from the dealer or one of the forum sponsors that sells oem parts.

I emailed eMoto and ferracci but got no reply from them.
I got reply from motowheels but they don't have that part.

Could anybody in this forum help me? at least, give me a valid email address or contact from a good dealer.

Thanks a lot.
russell910 is offline  
post #5 of 10 (permalink) Old 01-31-2010, 12:08 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
Forget eMoto....and Feracci customer service seems to have fallen apart. Where are you?

If in the USA, there are some good dealers around. Go to http://www.mvagustausa.com/web-mvagu...erlocator.html

call the dealer nearest you and start a relationship.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #6 of 10 (permalink) Old 01-31-2010, 05:59 AM Thread Starter
Established Member
 
russell910's Avatar
 
Join Date: May 2007
Posts: 125
Send a message via Yahoo to russell910
Quote:
Originally Posted by esq'z me View Post
Forget eMoto....and Feracci customer service seems to have fallen apart. Where are you?

If in the USA, there are some good dealers around. Go to http://www.mvagustausa.com/web-mvagu...erlocator.html

call the dealer nearest you and start a relationship.

I am living in Indonesia and no MV distributor here..
We have harley and ducati but no MV.

Thanks brother...
russell910 is offline  
post #7 of 10 (permalink) Old 01-31-2010, 06:27 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
If you have no luck finding a dealer, let me know. I will order one from a dealer here in the US and send it to you.

I think Vesuvio, a forum sponsor, stocks OEM parts.
CAG is offline  
post #8 of 10 (permalink) Old 01-31-2010, 08:10 AM Thread Starter
Established Member
 
russell910's Avatar
 
Join Date: May 2007
Posts: 125
Send a message via Yahoo to russell910
Quote:
Originally Posted by CAG View Post
If you have no luck finding a dealer, let me know. I will order one from a dealer here in the US and send it to you.

I think Vesuvio, a forum sponsor, stocks OEM parts.
Thank you very much brother... really appreciate the offer.
Right now I am waiting a reply from moto-tech.
Hope they have the part..
russell910 is offline  
post #9 of 10 (permalink) Old 02-19-2010, 02:41 AM Thread Starter
Established Member
 
russell910's Avatar
 
Join Date: May 2007
Posts: 125
Send a message via Yahoo to russell910
The SPU arrived and I have installed it. It works perfect!
Thank you so much to all of you and special thanks to Brian from www.moto-tech.biz for the very speedy response.

Now what I wondering is.. how could I broke my SPU? my bike still 5000km... ??
russell910 is offline  
post #10 of 10 (permalink) Old 02-19-2010, 08:24 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
You didn't break it...it was a defective part. Either poor weather sealing or poor solder connections inside or just undersized relays utilized in construction....but new parts are improved.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome