Back on the Brute - MVAgusta.net
 2Likes
  • 2 Post By RDBM
  • 2 Post By RDBM
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-03-2018, 01:23 PM Thread Starter
New Member
 
Join Date: May 2018
Posts: 8
Back on the Brute

After being away from the Forum for a few years, Iíve decided to make the time to get back out on the Brutale. Weather permitting and a passed MOT tomorrow Iíll be heading out for a ďget to know you againĒ ride.
Really looking forward to it as other than starting it up every now and then the bike hasnít been off the stands for 2 years.
Attached Images
 
Edward and Edward like this.
RDBM is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-03-2018, 02:08 PM
Senior Member
 
bogie's Avatar
 
Join Date: Jul 2015
Location: Notts, UK
Posts: 497
New Site Garage
Good for you, at least the weather is nice for the weekend ...bike looks in great condition

cheers
bogie
_________________
2015 Brutale 1090RR
bogie is offline  
post #3 of 6 (permalink) Old 05-04-2018, 05:48 AM Thread Starter
New Member
 
Join Date: May 2018
Posts: 8
Well, looks like Iím going nowhere this weekend. Bike failed MOT due to no indicators, guess who needs a new
SPU !!!!

Seems time has taken its toll and the dreaded Brutale SPU meltdown has caught up with me.
RDBM is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 05-04-2018, 05:56 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,935
Send a message via Skype™ to esq'z me
Well that just sucks..... You are sure it's the SPU?

I take it all indicators light up, just don't blink? Or do they not come on at all? Fuses all checked OK?

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is offline  
post #5 of 6 (permalink) Old 05-04-2018, 06:32 AM Thread Starter
New Member
 
Join Date: May 2018
Posts: 8
Quote:
Originally Posted by esq'z me View Post
Well that just sucks..... You are sure it's the SPU?

I take it all indicators light up, just don't blink? Or do they not come on at all? Fuses all checked OK?
Afraid so, showing all the Classic signs, they blink when setting alarm but nothing when using the turn switch. Headlight now stays on when engine switched off so pretty much resigned to getting replacement.

Have an ISO ad up now so hopefully someone will have one. Really donít want to pay £400 for a new one but will give it a few days and see if anything comes up. If not will just have to part with the cash as Iím not having it sitting doing nothing in the garage for another summer.
esq'z me and esq'z me like this.
RDBM is offline  
post #6 of 6 (permalink) Old 05-10-2018, 09:27 PM
New Member
 
Join Date: Jun 2017
Posts: 50
bummer on the failed part,
any idea what damaged it ?

Do you have any way to test your system before you install a new part?
any chance you can swap it into another machine to see if it works

2013 Brutale 1090 RR ABS
Philly PA USA
mrmerlin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome