Power comander - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-07-2009, 02:44 AM Thread Starter
 
Join Date: Jan 2007
Posts: 66
Power comander

Hi Right i have had the fuse/cdi box replaced and it still cuts out when itss hot and i stop at the lights etc, they have ordered me a new ephram chip in the hope that that cures it.

I have also just ordered an arroew carbon stubby, do you think it is worth adding a power comander and setting it up on the Dyno, the warrenty runs out in march so i am getting a bit concerned
dave765 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-07-2009, 03:03 AM
Senior Member
 
danstoppable's Avatar
 
Join Date: Mar 2007
Location: The Pittsburgh of the North East
Posts: 572
I'd say that you should see what the eprom does for you before going all out and getting a PCIII, 'cause I'd figure that'd be the end of your warranty. Nonetheless, we (as a board) have blathered intensely regarding this problem and the solutions vary pretty much by each bike (I just deal with the stalling, myself).

Anyways, the Arrow'll pretty much require either a custom eprom or a PCIII, 'cause it'll change the flow of the bike pretty intensely. I'd say that once you get the eprom and your problem isn't solved, get a PCIII, install the stubby and load up the map that Power Commander lists on their website. From there, just enjoy the bike at higher speeds. Red lights are stupid and unnecessary.

Time is a delusion. Lunchtime doubly so.
danstoppable is offline  
post #3 of 6 (permalink) Old 03-07-2009, 03:04 AM
Senior Member
 
danstoppable's Avatar
 
Join Date: Mar 2007
Location: The Pittsburgh of the North East
Posts: 572
I just repeated myself quite a lot there. My bad.

Time is a delusion. Lunchtime doubly so.
danstoppable is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-07-2009, 04:50 AM
The Dude
 
TokyoLunch's Avatar
 
Join Date: Apr 2006
Location: Tokyo, Japan
Posts: 5,041
PCIII didn't do anything for my stalling. Maybe it did for a bit, I thought so, but of course you would think it helped after dropping a some coin on it.

Still have issues here and there with stalling. Also with left blinker coming on sort of randomly. Seems to come on several seconds after using the right blinker.

that black box (whatever it is called, cartridge thing by the fuses) was replaced for several hundred dollars. still same issues. I'm just careful coming to a stop to give it a tiny bit of throttle slowing down so it doesn't crap out on me.

I assume you've got a 910S?


'06 MV Agusta Brutale 910 || '03 MV Agusta F4 750 - Moto Corse Challenge 2 || '05 Yamaha FJR1300A || '04 Honda CBR600RR || '96 Honda XR250 || '90 Honda CBR250RR (MC22) || '89 Honda VT250 Spada


Tokyo, Japan
TokyoLunch is offline  
post #5 of 6 (permalink) Old 03-07-2009, 07:15 AM
lee
Senior Member
 
lee's Avatar
 
Join Date: Oct 2007
Location: As far away from mankind as I can get
Posts: 5,076
I can't help you with an MV but can give you my experience with my Duc 1098 and hope it might help.

I installed a PC on the Duc. For several reasons. It came with a "dynoed map" for the ECU and exhaust on the bike. It was worse than the stock ECU map. I have since installed a different exhaust and gotten another "dynoed map" for it. Even more worse. Back to the stock map again. There is only one way to map a PC and that's to get it dynoed for a custom map for the particular bike.

I'm not sure about the MV as I've never had a stalling problem with mine, but the Duc had a stalling problem when coming to a stop. The idle rpm was set at 1350. Because the CR is 12.5:1 and the rotating mass within the engine is so light I feel that when hot and at 1350 rpm it didn't generate enough inertia to get it "over the hump" on the compression stroke. The idle was increased to 1550 rpm and the stalling is gone.

I don't know if this helps but i would certainly agree that you should investigate potential prolems with your engine as it is now before going to a PC. They really aren't all they're cracked up to be.

I got mine. Boy do I ever got mine.
lee is offline  
post #6 of 6 (permalink) Old 03-07-2009, 07:43 AM Thread Starter
 
Join Date: Jan 2007
Posts: 66
Cheers all, its aa 910R
dave765 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome