No Power Brutale: SPU - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 10-13-2008, 01:50 AM Thread Starter
Senior Member
 
rents's Avatar
 
Join Date: Sep 2006
Location: Adelaide, Australia
Posts: 968
Question No Power Brutale: SPU

My Brutale doesn't have stalling issues, but it has complete power loss issues (I believe fazer6's symptoms appear similar to mine). I've been looking down the path of replacing the service power unit (SPU) - also known as the fuse/relay box.

I'd been led to believe that the new, updated SPU - part # 8A00A9300 was backwards compatible with all Brutales. However the tech services manager for the Aus MV distributor has emailed me this -

"Depending on the vin # of your bike, if it is 004322 and above it takes 8A00A9300.
If it is 004321 or below it takes 8A00A9615.
The wiring loom is different in each vin range and SPU is not interchangeable."

Can anyone confirm or deny this? I'll be checking my VIN # later.

For reference my bike has lost all power (no dash, no engine etc) 3 times -

- A year ago on Philip Island I lost all power (bike shut off) at approx 160km/h hard on the throttle (took out key, key back in and power was back)
- 2 months ago no power when I went to turn it back on after a ride half an hour earlier, 20 minutes later it decided to give power
- Last Friday idling in traffic whilst warm (~95c running temp). 10 minute wait and I had power back.

Cheers guys
rents is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 10-13-2008, 11:57 AM
Senior Member
 
Street Fighter's Avatar
 
Join Date: Sep 2006
Posts: 350
No Power or the engine isnt running?
Be more clear about it.
It sounds like the engine is turning off right.
Street Fighter is offline  
post #3 of 23 (permalink) Old 10-13-2008, 02:41 PM Thread Starter
Senior Member
 
rents's Avatar
 
Join Date: Sep 2006
Location: Adelaide, Australia
Posts: 968
Yes, the engine stops because the power cuts out completely.
rents is offline  
Sponsored Links
Advertisement
 
post #4 of 23 (permalink) Old 10-13-2008, 02:50 PM
Senior Member
 
fazer6's Avatar
 
Join Date: Mar 2006
Location: Tempe, AZ, USA
Posts: 8,920
Do you know if the serial # is visible w/o taking the tank off?

If so, I will check my Vin and part# tonight.
fazer6 is offline  
post #5 of 23 (permalink) Old 10-13-2008, 04:11 PM
Established Member
 
Join Date: Jun 2008
Location: McDonough, GA
Posts: 134
Send a message via AIM to drewkbell Send a message via Yahoo to drewkbell
Does he mean for the 2004 models and VIN? I was told by both FBF and Atlanta Triumph Ducati that the 8000A9300 will fit the 2005 Brutale S. My VIN ends in 100393.

Did he reference part no. 8A00A9300 or 8000A9300?

I guess time will tell whenever it shows up.

Last edited by drewkbell; 10-13-2008 at 04:15 PM.
drewkbell is offline  
post #6 of 23 (permalink) Old 10-13-2008, 04:31 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
Quote:
Originally Posted by fazer6 View Post
Do you know if the serial # is visible w/o taking the tank off?

If so, I will check my Vin and part# tonight.
VIN is stamped on frame at steering head. Right side. Easy to see. Part number on SPU is not so easy to see.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #7 of 23 (permalink) Old 10-13-2008, 05:01 PM
Senior Member
 
fazer6's Avatar
 
Join Date: Mar 2006
Location: Tempe, AZ, USA
Posts: 8,920
Quote:
Originally Posted by esq'z me View Post
VIN is stamped on frame at steering head. Right side. Easy to see. Part number on SPU is not so easy to see.
The VIN I know, but where is the part number for the power unit?
fazer6 is offline  
post #8 of 23 (permalink) Old 10-13-2008, 05:26 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
Quote:
Originally Posted by fazer6 View Post
The VIN I know, but where is the part number for the power unit?
Usually on the back side, may be on a paper label.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #9 of 23 (permalink) Old 10-13-2008, 05:27 PM
Established Member
 
Join Date: Jun 2008
Location: McDonough, GA
Posts: 134
Send a message via AIM to drewkbell Send a message via Yahoo to drewkbell
I've got my SPU off and it doesn't have the part number listed.
drewkbell is offline  
post #10 of 23 (permalink) Old 10-13-2008, 05:43 PM
Established Member
 
Join Date: Jun 2008
Location: McDonough, GA
Posts: 134
Send a message via AIM to drewkbell Send a message via Yahoo to drewkbell
I have to admit, now I am kind of nervous about the part I am getting (8000A9300) from my parts order.
drewkbell is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome