ANYONE else have Turn signal problems?? - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-31-2006, 12:48 AM Thread Starter
Established Member
 
Join Date: Nov 2005
Location: Denver
Posts: 154
ANYONE else have Turn signal problems??

looking for reports
MikeDanger is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-31-2006, 01:02 AM
The Dude
 
TokyoLunch's Avatar
 
Join Date: Apr 2006
Location: Tokyo, Japan
Posts: 5,041
what kind of probs?
mine seem to work fine. recently put on the clear lenses.
still blinking.
TokyoLunch is offline  
post #3 of 7 (permalink) Old 05-31-2006, 02:09 AM
Senior Member
 
ddnuts's Avatar
 
Join Date: Jul 2005
Location: Northwest
Posts: 604
Send a message via Yahoo to ddnuts
I've been having turn signal problems for a while. I have LED rear signals and regular fronts and they blink fine until I get moving and the engine is reved up. I chaged the relay, but that didn't seem to make a difference. I'm going to replace all of the bulbs with LED lights in hopes that the change will take care of the problem. I don't know what to do about it.

Personality is what you show of yourself daily.

Character is what comes out under adversity. (Think about that)
ddnuts is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-31-2006, 03:00 PM
 
Join Date: May 2006
Posts: 38
Both our bruties run their indicators (standard) at a faster blink rate now and again for a couple of blinks. Read somewhere on the internet that someone got it fixed with an ECU swap... may be confused on that though, I would check first.
blackbruty is offline  
post #5 of 7 (permalink) Old 05-31-2006, 03:22 PM
Senior Member
 
Matty's Avatar
 
Join Date: Jul 2005
Location: Manchester Connecticut
Posts: 1,331
Send a message via AIM to Matty
if you got the clear plastic flasher relay for after market blinkers check to see if it has deformed on the outside at all....when mine got hot it was suck in the sides and would stop the relay from moving and pretty much froze the blinkers. I just went to an autoparts store and replaced the clear plastic one with a 3 dollar metal outside one. no problems yet.
Matty is offline  
post #6 of 7 (permalink) Old 05-31-2006, 04:04 PM
Senior Member
 
JamesC's Avatar
 
Join Date: Jul 2005
Location: DFW, TX USA
Posts: 1,937
Quote:
Originally Posted by blackbruty
Both our bruties run their indicators (standard) at a faster blink rate now and again for a couple of blinks. Read somewhere on the internet that someone got it fixed with an ECU swap... may be confused on that though, I would check first.

That's correct. You can check the thread on brutaleforum for my reply on the subject. Someone else also mentioned there were ground problems causing some of the issues.

Brutales use the ECU rather than a relay.

JamesC

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JamesC is offline  
post #7 of 7 (permalink) Old 05-31-2006, 04:19 PM
Senior Member
 
fazer6's Avatar
 
Join Date: Mar 2006
Location: Tempe, AZ, USA
Posts: 8,920
Mine blink irregularly, suspected to be a poor ground. However, it doesn't really bother me.
fazer6 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome