910r Arrow Thunder Exhaust & BMC - now stalls! - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 12-21-2007, 08:43 AM Thread Starter
New Member
 
Join Date: May 2007
Location: LaBelle, FL
Posts: 66
Exclamation 910r Arrow Thunder Exhaust & BMC - now stalls!

I put my Arrow Thunder on my 07 as soon as I bought the bike. Along w/a BMC air filter. My bike randomly stalls. However, since I upgraded the bike immediately, I don't know if it's a result of my setup or something else wrong w/the bike. Seems to only do it @ only low RPMS. I can usually "feel" the bike about to do it. I will even stall @ idle sometimes. & once it does start stalling, it stalls & stalls, & stalls & gets progressively worse.

It's only when Idling or coming to a stop that it does it. I have to be ultra paranoid when i am stopped & keep it revved to about 2500 rpm or else the bike is often likely to stall.

I have no power commander. I did NOT have the dlr install the race chip as i read from a few posts on here that it destroyed the gas mileage. Being the bike is all but a daily driver for me, I didn't want to have to stop for gas all the time.

Does the bike need to be tuned after installing these things? I know that I could get more HP & better power curve by having it properly tuned, but is it neccessary?

Would a power commander & one of the maps downloaded from PC's website fix it?

The MV Agusta dlr where I'm having the bike serviced is fairly new to the brand & I don't think they've had enough time to experience any common quirks these bikes might have.

Thanks in advance for your input.

On a lighter note, the Arrow Thunder looks & sounds GREAT!
hahaha

2007 910r \ 2004 Yamaha R1 \ 2008 848 \ 2007 F4
jessewallace is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 12-21-2007, 08:56 AM
Established Member
 
simonmv's Avatar
 
Join Date: Sep 2006
Location: Atlanta
Posts: 131
your bike needs to be tuned with all the changes. My 910r had the same issues when we put the factory race exhaust on. The solution for me was to switch back to the factory chip instead of the race chip and then tune the bike. It took them a while to figure this out.
simonmv is offline  
post #3 of 16 (permalink) Old 12-21-2007, 08:57 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
If the bike has been prperly tuned, then it sounds like the fuel tank vent system is restricted. Have you noticed it is worse when the tank is full?

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 12-21-2007, 09:00 AM Thread Starter
New Member
 
Join Date: May 2007
Location: LaBelle, FL
Posts: 66
The bike has had no tuning. The pipe & air filter were installed w/out any adjustments.

2007 910r \ 2004 Yamaha R1 \ 2008 848 \ 2007 F4
jessewallace is offline  
post #5 of 16 (permalink) Old 12-21-2007, 09:04 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
Quote:
Originally Posted by jessewallace
The bike has had no tuning. The pipe & air filter were installed w/out any adjustments.
At the very least, you need to have your idle trim and TPS set, and possibly throttle body synch. You probably need a race chip, or power commander to compensate for all the changes made in engine breathing. Get to the dealer or competent Italian bike tuner.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)

Last edited by esq'z me; 12-21-2007 at 09:06 AM.
esq'z me is offline  
post #6 of 16 (permalink) Old 12-21-2007, 10:15 AM
Established Member
 
Metallo Brutale's Avatar
 
Join Date: May 2006
Location: Lost Angeles
Posts: 144
If I may interject, I have and still continue to have the same problems as jessewallace. (I too have the Arrow shorty, BMC, and iridium plugs.) I have the race chip on my R, plus I have a PC Commander AND I had the bike dynoed. ProItalia refused to put on the PC Commander (citing, though it doesn't void the warranty, any mods to the bike, such as exhaust, filter, EFI module or plugs automatically change the "very precise" tuning of the bike.) I think I have the worst mpg of any Brute R here on the board, a meager 17mpg. With the dyno, I now get 20mpg. And, like jessewallace, my bike stalls when de-accelerating, downshifting, accelerating from a full stop or slowing to a stop. Once, it took a full three seconds to kick over from a cold start. I'm baffled and frustrated at having to, like him, ready myself for the inevitable engine cut off while riding. I could easily have the bike re-dynoed (and after reading Airfuel's lengthy explanation of how a dyno SHOULD be performed (on another post)), I start to wonder if the dyno I got was performed correctly or if it could be yet another Brutale bug.
Metallo Brutale is offline  
post #7 of 16 (permalink) Old 12-21-2007, 11:14 AM Thread Starter
New Member
 
Join Date: May 2007
Location: LaBelle, FL
Posts: 66
I just got off the phone w/the dlrship who is looking into the problem now & asked them if they thought my stalling might have something to do w/my aftermarket exhaust setup / BMC air filter. They said they had already wondered that & when they hooked it up to the computer everything was in it's proper parameters.

I also forgot to mention earlier that I sometimes hear an noise right before it stalls that sounds like air pressure being released. it is very faint & very quiet, but the guys at the dlrship have heard it too.

The only reason I haven't put the race chip in is b/c the drop in gas mileage that so many people complain about. 20mpg isn't really acceptable on a daily driver motorcycle.

2007 910r \ 2004 Yamaha R1 \ 2008 848 \ 2007 F4
jessewallace is offline  
post #8 of 16 (permalink) Old 12-21-2007, 11:18 AM Thread Starter
New Member
 
Join Date: May 2007
Location: LaBelle, FL
Posts: 66
Anybody have a tuner they could highly reccomend in the south FL area to properly tune my brutale?

2007 910r \ 2004 Yamaha R1 \ 2008 848 \ 2007 F4
jessewallace is offline  
post #9 of 16 (permalink) Old 12-21-2007, 11:59 AM
Senior Member
 
Flat Spot's Avatar
 
Join Date: Dec 2007
Location: Suwanee, GA
Posts: 475
I'm about to install this exact setup. I hope I don't have the same problems.
Flat Spot is offline  
post #10 of 16 (permalink) Old 12-21-2007, 01:42 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,145
Send a message via Skype™ to esq'z me
Can't speak to your exact set-up, but can't believe the bikes would not need some adjustment after installing MUCH more free flowing exhaust as well as a high flow air cleaner. A good technician who knows these Magnetti Marelli systems is needed.

Regardless of that, the sound you hear....I go back to the possible pinched fuel tank vent hose. Have you ever noticed you have to pull open the gas cap against a vacuum when refueling? Does your stall problem seem worse when the tank is full? These would indicate your pump is struggling to pull gas out of a sealed up tank generating vacuum and possible low flow, hence stall at short injector duration periods (idle).

Just a thought....good luck. My 910r has stalled exactly twice. Both times just after fill up and pulling to a stop. Both times in the week before I un-pinched the vent hose I inadvertanly misrouted when I had the tank off before whilst installing my alarm system. Otherwise, 3500 miles of pure bliss and reliable power. Oh, yeah... and 31~35 mpg.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome