Bike wont start full injector keeps making noise - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-12-2014, 10:49 AM Thread Starter
New Member
 
Join Date: Sep 2013
Posts: 72
Bike wont start full injector keeps making noise

Did a short ride just then in the rain on the brutale 920

Went to ride home the electrics turn on as normal and the normal fuel injector noise but it does not stop the electric fuel injector sound?
(edit sorry its a fuel pump noise , keeps going )

Bike wont crank or turn over\ no click noise or anything
no petrol leaking and i have a full tank

never had it before , is it flooded or something weird

checked the electrics are all dry under the seat

checked its not the bike kill switch or the stand sensor ..

Last edited by hotsuma; 06-12-2014 at 10:58 AM.
hotsuma is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-12-2014, 11:18 AM
col
Senior Member
 
col's Avatar
 
Join Date: Sep 2009
Posts: 1,697
New Site Garage
have you checked the neutral and or the side stand switch
and fuses

i have a form of dislexia as i have said plenty of time and it dont bother me .................. but im not stupid or a tard so dont try it on


MV Brutale's go faster than a crackheads dole payment and that's fast

I WAS A BIKER BEFORE IT BECAME A FASHION STATEMENT
col is offline  
post #3 of 6 (permalink) Old 06-12-2014, 11:40 AM Thread Starter
New Member
 
Join Date: Sep 2013
Posts: 72
Quote:
Originally Posted by col View Post
have you checked the neutral and or the side stand switch
and fuses

Yeah took it in and out of neutral, it should fire in neutral even with the stand down but won't, actuated the button the stand uses etc, ill check the fuses in the morning going have to chance leaving it there

ive read a couple of the other people with issues , in the morning ill open the tank and see if i can see petrol ripples (fuel pump tube issue)
where is the sensor for the clutch?, you need to pull that for it to fire even in neutral ill check that too

and ill check the fuses

sigh , hope its just magically fine in the morning
hotsuma is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-15-2014, 08:31 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,886
Send a message via Skype™ to theknurl
Wink

hotsuma;

the clutch switch is on the bottom of the clutch lever mount.....

Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is online now  
post #5 of 6 (permalink) Old 06-16-2014, 12:14 AM
Senior Member
 
Reckler's Avatar
 
Join Date: Apr 2013
Location: Calgary, Alberta
Posts: 1,549
New Site Garage
Any luck sorting your issue? Did it actually magically work when you went back for it?

Sent from Motorcycle.com Free App

Speed is relative, but fast is fast.

- 2011 brutale 1090R (Matte pearl white/Black)
Reckler is offline  
post #6 of 6 (permalink) Old 06-17-2014, 10:13 PM
Senior Member
 
psycho16161's Avatar
 
Join Date: Feb 2010
Location: Geelong, Australia
Posts: 277
Send a message via Yahoo to psycho16161
Good call Noel, just had a clutch switch problem, pulled the connector under the clutch lever, bridged them together & it started straight away, touched up connectors with emery paper & contact cleaner, all good now. Try that Reckler.
psycho16161 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome