my mechanic may need some help w/my F3 - MVAgusta.net
 6Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 10-13-2019, 06:23 PM Thread Starter
Senior Member
 
bioluminescence's Avatar
 
Join Date: Feb 2012
Location: oakland, ca
Posts: 289
New Site Garage
my mechanic may need some help w/my F3

He completed the 7.5k mile service, & works on a lot of MV's, but says he's having trouble with the fuel pump,

"wish I could tell you the bikeís all set to go, unfortunately the fuel pump issue is
still not resolved.

Iíve disassembled and double-checked all the work done during the
course of the service, tested the fuel pump and the wiring from the
harness, Iíve checked all connectors, lines and wires relating to fuel
as well the tip over sensor and anything else that might control the
pump. Iíve confirmed the good condition of the battery and as yet do
not see why the fuel pump is not correctly priming.

I will continue on it tomorrow and contact the dealer for insights on
Tuesday if I havenít figured it out by then, please let me know if you
have any questions and Iíll be in touch as it progresses."
it is the newest sprag design, and i wrote back telling him it typically takes a bunch of cranks to start on the first start of the day. not sure if that's related.
wondering if you guys know anything else, or some MV voodoo, he can check.

Nighthawk 650 '83 prune/gunk
FZR 600 '93 red/white
F4 750 '03 red/silver
F3 800 '16 ABS red/silver
bioluminescence is online now  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 10-13-2019, 07:22 PM
Established Member
 
Figifister's Avatar
 
Join Date: Jul 2019
Location: Phoenix Az
Posts: 151
What about a fuel filter. Could be clogged. Or bad gas that has gunked up the pump.

Does he have the ability to hook a computer up and isolate just the fuel pump and cycle the pump on and off?

Can you hear it whining when you cycle the key?


Sent from my SM-G930V using Tapatalk
PTsalas likes this.
Figifister is offline  
post #3 of 17 (permalink) Old 10-15-2019, 06:20 PM Thread Starter
Senior Member
 
bioluminescence's Avatar
 
Join Date: Feb 2012
Location: oakland, ca
Posts: 289
New Site Garage
Just visited him today. You can hear the pump priming when the key is turned on. Then when starting, lots of cranking and no turning over.
He installed a new filter, but plans top put the old one back in and try a stock battery, since mine is lithium now...
the valve check went smooth, all the clearances checked out. but getting it back together has been a headache.
hopefully will get sorted out soon.

Nighthawk 650 '83 prune/gunk
FZR 600 '93 red/white
F4 750 '03 red/silver
F3 800 '16 ABS red/silver
bioluminescence is online now  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 10-16-2019, 08:22 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
Quote:
Originally Posted by bioluminescence View Post
... Then when starting, lots of cranking and no turning over.
What does this mean?
esq'z me likes this.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 17 (permalink) Old 10-16-2019, 09:03 PM
MVAgusta.net Sponsor
 
mitchy's Avatar
 
Join Date: Feb 2010
Location: Gold Coast, Australia.
Posts: 5,089
New Site Garage
Send a message via Skype™ to mitchy
Is there fuel pressure to the injector rail.
That is what I would check next,but your mechanic should know that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Bike- F4 1078 312rr
Work.Email & Paypal.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Work Phone (+61)0755244655
Facebook- Mitch Covington
Mobile-0423041326
mitchy is offline  
post #6 of 17 (permalink) Old 10-16-2019, 10:42 PM
Established Member
 
Figifister's Avatar
 
Join Date: Jul 2019
Location: Phoenix Az
Posts: 151
Quote:
Originally Posted by mitchy View Post
Is there fuel pressure to the injector rail.
That is what I would check next,but your mechanic should know that.
True^^^^

Also I would ohm test the injectors. They may be out of range and/or have a clogged hole and need to be cleaned and flow tested. I doubt your injectors are out of ohm spec but it takes 5 seconds per injector and he is already in there. It's more likely they need to be cleaned and flow tested....If they indeed are getting fuel pressure to the rail....if not then check the fuel pressure regulator.

And get a new mechanic lol just kidding but sort of not....


Sent from my SM-G930V using Tapatalk
Kageira and Brutale800RR like this.
Figifister is offline  
post #7 of 17 (permalink) Old 10-17-2019, 06:55 AM
Senior Member
 
PTsalas's Avatar
 
Join Date: Apr 2012
Posts: 1,423
What did it do before, what did you change and what is it doing now? That should lead you in the right direction.

BTW , the manual calls for removing of a fuse after an oil change , cranking it a few times then replacing the fuse. Think it is the fuse for the fuel pump or ignition. I would check that. Maybe he removed the fuse and forgot to put it back?
PTsalas is offline  
post #8 of 17 (permalink) Old 10-17-2019, 07:22 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,507
Send a message via Skype™ to esq'z me
Wonder if the hose has popped off the pump inside the tank......

It ran before the valve check, right? And now, on re-assembly, it doesn't?

Happened to me once.... had the tank off for a while, put it back on and no start....hose popped off the pump.
silentservice703 likes this.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #9 of 17 (permalink) Old 10-17-2019, 09:23 AM
Senior Member
 
number2's Avatar
 
Join Date: Jan 2009
Location: Charleston South Carolina
Posts: 5,730
Quote:
Originally Posted by esq'z me View Post
Wonder if the hose has popped off the pump inside the tank......

It ran before the valve check, right? And now, on re-assembly, it doesn't?

Happened to me once.... had the tank off for a while, put it back on and no start....hose popped off the pump.

if the hose is off then you should see a lot of swirling in the tank when the pump is priming
number2 is offline  
post #10 of 17 (permalink) Old 10-17-2019, 03:51 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
Quote:
Originally Posted by number2 View Post
if the hose is off then you should see a lot of swirling in the tank when the pump is priming
Not necessarily.....
esq'z me likes this.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome