Severe hunting Brutale B3 - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 04-29-2019, 08:03 AM Thread Starter
New Member
 
jeroen.surf.nl's Avatar
 
Join Date: Aug 2018
Location: The Netherlands
Posts: 25
Severe hunting Brutale B3

Hello everyone, my Brutalia is giving me more grief than joy at the moment
The top end is fine, above ~4000 rpm she goes like mad, but below she's almost undrivable.
The issue is that with constant throttle the revs go up and down like crazy.
See youtube video, listen to the audio. This is with steady throttle in neutral. When driving the same issue, causing really hard jerks and impossible to drive.

Anyone any tips or insight about a possible cause? Thanks!


'13 Brutale 800 Italia color scheme
The Netherlands
jeroen.surf.nl is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-29-2019, 08:49 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
This is standard B3 800 RR driveability. Get into your dash menu and change your throttle response.

FWIW, performance below 4000rpm is shaky at best across the line due to ECU tuning.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 13 (permalink) Old 04-29-2019, 09:09 AM Thread Starter
New Member
 
jeroen.surf.nl's Avatar
 
Join Date: Aug 2018
Location: The Netherlands
Posts: 25
Is this something that can be solved by tuning on a dyno you think?

'13 Brutale 800 Italia color scheme
The Netherlands
jeroen.surf.nl is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 04-29-2019, 09:44 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
Yes, it can if you have a tuner that can get into your ignition tables and fuel tables.

The fueling is a mess below 4000 rpm as is the ignition timing.

In the meantime, there are adjustment you can make through the dash in Custom Mode that will help.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 13 (permalink) Old 04-29-2019, 10:15 AM Thread Starter
New Member
 
jeroen.surf.nl's Avatar
 
Join Date: Aug 2018
Location: The Netherlands
Posts: 25
Ok time to go to the tuner then I guess Thanks for the help Silentservice703!

'13 Brutale 800 Italia color scheme
The Netherlands
jeroen.surf.nl is offline  
post #6 of 13 (permalink) Old 04-29-2019, 11:05 AM
whp
Established Member
 
whp's Avatar
 
Join Date: May 2013
Location: Germany, Hessen
Posts: 124
thats not normal! Maybe you didnt get any ecu update on your bike? Seems lika an italia so this must be 2012-2015 and if its an early one maybe it never seen any update! There were several updates for the b3s! Go to a dealer first an let them update the ecu. If the problem still ist there you need to find the problem.

btw did you realy got 50000 kms on the b3? And if so this problem wasnt there at the beginng? Then there must be something wrong, maybe airleak, damaged
lambda probe...

Life is short....

Kawasaki Zx6r 1999 green 'Sold' 1999-2012
B3 675 2012 white 'SOLD' 2012-2015
B3 800 2015 grey 'NEW' 2015 -
Kawasaki zx6r 1998 green ŽoldŽ2016 -

SUBSCRIBE PLS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by whp; 04-29-2019 at 11:08 AM.
whp is offline  
post #7 of 13 (permalink) Old 04-29-2019, 11:29 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
Sounds like a cold MV trying to run.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #8 of 13 (permalink) Old 04-29-2019, 11:31 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
So, the question is: What maintenance has been done to the bike? Fuel system serviced?

Honestly, I didn't watch the video until now. It is hunting. Causes can be vacuum related or fuel related.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #9 of 13 (permalink) Old 04-29-2019, 12:46 PM Thread Starter
New Member
 
jeroen.surf.nl's Avatar
 
Join Date: Aug 2018
Location: The Netherlands
Posts: 25
Well, I just found out the problem 100% ECU related. The mailman dropped by with a nice package I swapped my ECU for a dragster ECU with ABS (I mapped all the pins of both ECU's and all the pins match except speedo sensor and quick shifter) and, to my surprise, the bike now runs very very smoothly. The hunting is ~90% gone, barely noticable. Unfortunately I have to return the dragster ECU to the owner, but at least now I know the bike is OK and it's the ECU that needs work.

Quote:
Originally Posted by whp View Post
thats not normal! Maybe you didnt get any ecu update on your bike? Seems lika an italia so this must be 2012-2015 and if its an early one maybe it never seen any update! There were several updates for the b3s! Go to a dealer first an let them update the ecu. If the problem still ist there you need to find the problem.

btw did you realy got 50000 kms on the b3? And if so this problem wasnt there at the beginng? Then there must be something wrong, maybe airleak, damaged
lambda probe...
I bought it a year ago. Was a bit of a gamble The bike had 45000 km on it, but got its engine replaced at ~36.000 with an new engine. I got it for a very good price, so I gave it a shot. Changed all the fluids, brakes, spark plugs, and air filter. Fixed the rear hub issue. Did some thorough cleaning and polishing. The bike runs, steers and stops absolutely great, only the hunting at low rpm is a problem.

Quote:
Originally Posted by silentservice703 View Post
So, the question is: What maintenance has been done to the bike? Fuel system serviced?

Honestly, I didn't watch the video until now. It is hunting. Causes can be vacuum related or fuel related.
Well, that's a whole other story... So as said above I got the bike cheap and gave it some TLC. The hunting at low rpm was there all along, but not as bad as it is now. My guess was it still had some old firmware and maps so I decided to send out the ECU to get flashed with an "optimized" firmware and maps by a company named Carmo. They said it would take 2 days. After a week I called to check the status, and they said they had difficulties with my ECU and needed files from one of the tuners they work with. That didn't sound good at all and at that point I should have cancelled the operation but I asked them to continue. Couple days later my ECU was back... installed it... and the hunting was even worse than before. Terrible. I emailed them last week but got no response yet.

'13 Brutale 800 Italia color scheme
The Netherlands
jeroen.surf.nl is offline  
post #10 of 13 (permalink) Old 04-29-2019, 02:37 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,199
Send a message via Skype™ to silentservice703
Well, I suppose that is Lesson Learned. ECU tuning is best done at a Dyno Shop with instant readouts and real time tuning.

Gapalicious 2020 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from Sept. 23-Sept.27, 2020

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome