Turismo Veloce 800 cooling fan issue - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-17-2018, 03:29 AM Thread Starter
New Member
Turismo Veloce 800 cooling fan issue

Hello guys recently bought a Turismo Veloce 800 and only couple of weeks on the road noticed that coolant temperature goes over the 5 bars .I know the basics and start checking the possible reasons for that - cooling fan does not work .Test the fan itself with 12V and does work perfectly ,replace the radiator temperature sensor ,replace the relay and kept experience the same problem .After test all the usual component that can fail I did replace the engine Ecu.With the new Ecu when the coolant reached 80° fan start working only for like 5 secs .That happened when run the bike first time with new Ecu and then fan never worked again .Can anyone help ?
Ivan.ivanov758 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-17-2018, 07:53 AM
Senior Member
 
Bumpkin's Avatar
 
Join Date: Apr 2016
Location: Herefordshire, UK
Posts: 1,611
New Site Garage
How old is the bike? Should still be in warranty unless it's one of the early ones. I would be taking to your nearest MV dealer. Where about in the World are you located (useful to anyone responding and easy to add that to your profile).

My TVL does struggle to maintain temperature in certain circumstances (i.e. stuck in traffic) when the weather is hot but the fan always kicks in.

Chas
Previously a MY16 Turismo Veloce Lusso
Defected to a Ducati Multistrada 1260S Touring
Bumpkin is offline  
post #3 of 5 (permalink) Old 01-17-2018, 10:11 AM Thread Starter
New Member
I am in Uk .Bike is o e year old and got 550 miles on the clock ,but because got a tracker ,aftermarket alarm and sat nav installed dealership has been funny about the warranty .When the fan is suppose to kick in 80° 90° 100° ?
Ivan.ivanov758 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 01-18-2018, 01:55 AM
Senior Member
 
Gero HH's Avatar
 
Join Date: Mar 2016
Location: Hamburg, Germany
Posts: 520
New Site Garage
Hi Ivan,
you should download here (Donsy) the Workshop Manual for the TV...
Attached Images
 

Gero
______________________
2016 Turismo Veloce 800 Lusso
Gero HH is offline  
post #5 of 5 (permalink) Old 01-18-2018, 03:44 AM
Senior Member
 
Bumpkin's Avatar
 
Join Date: Apr 2016
Location: Herefordshire, UK
Posts: 1,611
New Site Garage
Quote:
Originally Posted by Ivan.ivanov758 View Post
I am in Uk .Bike is o e year old and got 550 miles on the clock ,but because got a tracker ,aftermarket alarm and sat nav installed dealership has been funny about the warranty
Sorry can't recall temperature in and out points but around 105ºC sounds plausible with it cutting out once temperature drops to around 95ºC and cycle thereon depending on conditions and airflow. Under normal conditions and when in motion forced airflow through the rad should suffice and the fan not be required.

The workshop manual only says "The electric fan must start up when the water temperature reaches the 5th or 6th notch on the dashboard."

Sounds to me like you need to use a different dealer. I have all the electrical accessories you mention and have had no issues with warranty claims. If you're in the South then Motocorsa, near Shaftesbury, gets a big thumbs up from me.

Chas
Previously a MY16 Turismo Veloce Lusso
Defected to a Ducati Multistrada 1260S Touring
Bumpkin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome