Battery Tender issues... - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-30-2016, 12:25 PM Thread Starter
Senior Member
 
Stephen W.'s Avatar
 
Join Date: Feb 2012
Location: Glen Ross on Trent, Ontario, Canada
Posts: 1,548
Battery Tender issues...

My 2013 F3 675 came with a Battery Tender Waterproof 800 Automatic.



I’ve used it faithfully as prescribed by MV. However, it died as did the two year old Yuasa battery that replaced the OEM unit. I’m now on my third battery in four years of ownership. I was told that the bike’s charging system is working fine.

Has anyone else had their tender pack it in?

the Dreamer
(a.k.a. Dreamin' Stephen)
Living life on the edge. Less crowded, better view.
2013 675 MV F3 Red Molly
1998 900 SS FE silFEr



Last edited by Stephen W.; 07-30-2016 at 12:55 PM.
Stephen W. is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-30-2016, 06:23 PM
Established Member
 
idsteve's Avatar
 
Join Date: Sep 2014
Location: NYC
Posts: 104
New Site Garage
I've never used it as I bought a Shorai and charger when I bought the bike. Be happy to send it to you if you want it. Send me a PM with info.
Cheers
Steve
idsteve is offline  
post #3 of 5 (permalink) Old 08-01-2016, 07:17 AM
Senior Member
 
PTsalas's Avatar
 
Join Date: Apr 2012
Posts: 1,405
Mine is 4 years old and still works a treat.

Never had problems with the OEM battery or charger though I did change to a LiPo battery as a precaution.
PTsalas is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-01-2016, 07:35 AM
Senior Member
 
Wildfire's Avatar
 
Join Date: Mar 2014
Location: London, UK
Posts: 465
Yep, mine died after about a year or so. I'd plug it in and it would take a few goes at getting the light turned on. I ended up actually just buying a new one off amazon, with a UK plug. Seems to be working fine, although I have been having an issue with starting a few times. But I am not that confident in my Yuasa battery to be honest. My brother has a CTEK, which I may have a go at connecting up to see if it helps, but I need the Superseal adapter plug.
Wildfire is offline  
post #5 of 5 (permalink) Old 08-01-2016, 02:40 PM
Senior Member
 
Join Date: Jan 2015
Location: Texas
Posts: 291
New Site Garage
If it is within your budget, perhaps you might consider making the switch to Shorai? It was one of the first things I did when I brought mine home and I bought their brand of charger to go with it and it works just fine.
Spark is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome