Took a bit but first service done... - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-26-2016, 01:01 PM Thread Starter
New Member
 
Join Date: Sep 2015
Location: Newcastle UK
Posts: 7
Took a bit but first service done...

Well after the issue i had getting my dragster RR last year (dealership issue with paperwork to get it registered in the UK took 3 months )

So finally get to the point where i find im due the first service, then to find out the dealership in newcastle (north east UK) has gone bust.. Quick google around and i find my next closest is Thirsk

Thankfully its only an hour away so not so bad, however they got the job done using there last in stock oil filter (with issues with MV they have an issue with parts and had 25 on back order).

All going well till today after a sprited ride home from work i pull onto the drive and it proptly drops its coolant and bubbles away, after double checking the overflow bottle after it cooled down i cant see anything in there....

Joys of MV (off to order some coolant now and hope its just gone a bit mad)

Andy

Apart from this minor coolant issue, totally love the bike.
Caoboth is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-26-2016, 01:37 PM
Senior Member
 
Jogort's Avatar
 
Join Date: Aug 2015
Posts: 590
New Site Garage
Coolant on the Dragster shouldn't be over the min line, mine for the first 8-10,000km was always a little under the min line and hard to see. Never had overheating issues. If it's filled past the min line it'll dump it out.

Current steed - MY16 Dragster RR
Previous Bike - 2008 Triumph Street Triple
Scottish and living it up in South East Spain
Jogort is offline  
post #3 of 6 (permalink) Old 06-27-2016, 03:46 AM
Senior Member
 
squidger's Avatar
 
Join Date: Sep 2014
Location: Horley Surrey
Posts: 258
Check your radiator cap. This is a known issue. Mine did the same on my Brutale. The cap has 2 valves. The big spring is on one and that was OK on mine. The centre valve which lets coolant flow back into the radiator was stuck on mine. After a lube up it hasn't been a problem since.
squidger is offline  
The Following User Says Thank You to squidger For This Useful Post:
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-27-2016, 04:12 AM
New Member
 
Join Date: May 2016
Location: Adelaide South Australia
Posts: 33
Quote:
Originally Posted by squidger View Post
Check your radiator cap. This is a known issue. Mine did the same on my Brutale. The cap has 2 valves. The big spring is on one and that was OK on mine. The centre valve which lets coolant flow back into the radiator was stuck on mine. After a lube up it hasn't been a problem since.
What did you lube it with?
stevenkelby is offline  
post #5 of 6 (permalink) Old 06-27-2016, 06:10 AM
Senior Member
 
Join Date: Dec 2014
Posts: 1,188
Sounds like an airlock to me - is a coolant change in the service?
Jono is offline  
post #6 of 6 (permalink) Old 06-27-2016, 01:35 PM
Senior Member
 
squidger's Avatar
 
Join Date: Sep 2014
Location: Horley Surrey
Posts: 258
I just exercised the pin and lubed with a drop of oil.
squidger is offline  
The Following User Says Thank You to squidger For This Useful Post:
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome