Veloce indicator - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-15-2016, 03:13 PM Thread Starter
New Member
 
Join Date: Jun 2016
Posts: 2
Unhappy Veloce indicator

Hi, just got back from Isle of Man TT with my Veloce. Bike was excellent and met some very friendly MV owners.
My only niggle with the bike is that the rear nearside indicator stopped working in March( took delivery Dec 15) . Unfortunately I purchased from Bikers Group who have gone into liquidation. Next nearest dealer is Leicester MV who are kindly doing the indicator under warranty , however I have now been waiting for 2 months and still no sign of replacement. They say they do not know when parts are coming from MV. Poor show on a brand new bike that I otherwise thinks great! Anyone else having similar issues?
Cheers Diggler
Diggler is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-15-2016, 04:22 PM
Established Member
 
r6ymy's Avatar
 
Join Date: Sep 2015
Location: Witney, Oxfordshire
Posts: 189
Hopefully you won't have to wait much longer, as parts are shipping again after several weeks of zero production while the factory financial and ownership wrangles are playing out.

Neville
Turismo Veloce
r6ymy is offline  
post #3 of 8 (permalink) Old 06-15-2016, 04:38 PM
Senior Member
 
Bumpkin's Avatar
 
Join Date: Apr 2016
Location: Herefordshire, UK
Posts: 1,618
New Site Garage
Whilst there was a hiccough with parts supply a month ago they do seem to be shipping again.

As to the indicator, my TV is in tomorrow having the the very same one replaced (works sporadically) along with the front off side hand-guard assembly (three out of 6 LEDs permanently out), both under warranty. Alerted dealer about this when I had my break-in service done on 22nd of May, they checked parts availability there and then and confirmed the rear one as available and the front one as shortly available. They've had the parts waiting for me to get up there for at least a week now, if not longer.

The indicators do seem to be a weak point, they seem particularly sensitive to water damage. Not great on a sports tourer, especially a premium one like the TV.

Will be asking if I can keep the old parts, though as warranty replacements I think I know the answer to that, so I can investigate and maybe repair to keep as spares and also look at making them more resilient. Conformal coating products spring to mind.

Chas
Previously a MY16 Turismo Veloce Lusso
Defected to a Ducati Multistrada 1260S Touring
Bumpkin is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 06-16-2016, 02:12 PM Thread Starter
New Member
 
Join Date: Jun 2016
Posts: 2
Quote:
Originally Posted by Diggler View Post
Hi, just got back from Isle of Man TT with my Veloce. Bike was excellent and met some very friendly MV owners.
My only niggle with the bike is that the rear nearside indicator stopped working in March( took delivery Dec 15) . Unfortunately I purchased from Bikers Group who have gone into liquidation. Next nearest dealer is Leicester MV who are kindly doing the indicator under warranty , however I have now been waiting for 2 months and still no sign of replacement. They say they do not know when parts are coming from MV. Poor show on a brand new bike that I otherwise thinks great! Anyone else having similar issues?
Cheers Diggler
Thanks for the info, i'll keep fingers crossed for a phone call.
Derek
Diggler is offline  
post #5 of 8 (permalink) Old 06-16-2016, 03:19 PM
Senior Member
 
Bumpkin's Avatar
 
Join Date: Apr 2016
Location: Herefordshire, UK
Posts: 1,618
New Site Garage
Had both rear left and front right indicators replaced by Jamie, Ed Cosker's tech. Discovered that front left is down to two LED. Not looking good for the future for these components, that's three out of four gone bad in one and a half months. Hopefully the design has been improved internally because continual failure isn't really a realistic proposition. Front left now on order, if it gets here next week Sam, parts and sales, offered to drop in and fit it at my house as he lives fairly local to me, which was nice.

Jamie also ripped out the non functioning MV approved alarm, don't ever consider getting one of these fitted, expensive piece of crap. Coskers will now refuse to fit these, both of the ones they've fitted have failed within a month. Was one hell of a job, lots of panels off and fiddly reaching in to cramped blind spots to disconnect the thing from various parts of the loom.

Another job tackled was the fitting of the new headlamp high beam adaptor. Will post elsewhere, and later, about where and how on the bike to fit this for those who have ordered and intend to self fit. First time they'd done one and with no instructions a voyage of discovery. Thought he'd found the connector to only discover that one side was good but the other didn't fit. At the end he had the nosecone, side panels and tank off to finally discover that the connector he originally found was one end of a similar adaptor which had to be removed and replaced with the new one... At least he'll know how it's done next time. Not a small job, nose cone needs to come off as well as left side panel.

Big thanks to both Jamie and Sam who both stayed late to get this sorted and me happily on my way. Even to the extent that they requested that I take it for a test ride to ensure everything was OK. Refused an attempt to tip them for their duty beyond the call as well. Can't recommend Ed and his staff enough.

Chas
Previously a MY16 Turismo Veloce Lusso
Defected to a Ducati Multistrada 1260S Touring
Bumpkin is offline  
post #6 of 8 (permalink) Old 06-16-2016, 04:24 PM
Established Member
 
r6ymy's Avatar
 
Join Date: Sep 2015
Location: Witney, Oxfordshire
Posts: 189
Quote:
Not a small job, nose cone needs to come off as well as left side panel.
Cheers, that gives me a clue where to look. Mine arrived this morning. Had a very quick look at the bike and couldn't see anywhere obvious to fit so thought panels would need to come off.

Neville
Turismo Veloce
r6ymy is offline  
post #7 of 8 (permalink) Old 06-16-2016, 06:22 PM
Senior Member
 
Bumpkin's Avatar
 
Join Date: Apr 2016
Location: Herefordshire, UK
Posts: 1,618
New Site Garage
Have a look here in the appropriate thread for more detail.

Chas
Previously a MY16 Turismo Veloce Lusso
Defected to a Ducati Multistrada 1260S Touring
Bumpkin is offline  
post #8 of 8 (permalink) Old 06-19-2016, 11:28 AM
Senior Member
 
TheX's Avatar
 
Join Date: Feb 2015
Location: Austin Texas USA
Posts: 445
I'm still waiting for a left taillight assy for my Rivale. This is the third one that's failed. We'll be at two months very soon.

Do something today that your future self will thank you for.
TheX is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome