F3 Coil 2 issue - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-25-2016, 11:57 PM Thread Starter
Established Member
 
iwannagofast's Avatar
 
Join Date: Oct 2015
Location: Australia
Posts: 177
New Site Garage
F3 Coil 2 issue

The bike was taking a few tries to start up and today it came up with a coil 2 issue.

On my phone so i cant search the forum.

Just wondering what is required to fix the fault. If coils need to be replaced and are they brought individually or as a set.
iwannagofast is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-26-2016, 12:28 AM
Senior Member
 
idahomike's Avatar
 
Join Date: Jan 2012
Location: Las Vegas, NV
Posts: 265
Send a message via Skype™ to idahomike
Quote:
Originally Posted by iwannagofast View Post
The bike was taking a few tries to start up and today it came up with a coil 2 issue.

On my phone so i cant search the forum.

Just wondering what is required to fix the fault. If coils need to be replaced and are they brought individually or as a set.
Check F1 first as it runs the coils and the fuel pump. Check the fuse with a meter, clean everything, use some dielectric grease if you have it and make sure a good fuse is seated firmly in the fuse block. That fixed my '13 F3 with the same problem.

Life Is Short, Eat Dessert First!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2007 Ninja 650R Candy Plasma Blue (Blue Thing) -SOLD
2013 F3 675 Red/Silver (Velocita) -SOLD
2014 899 Panigale Red (John Wayne)
2016 F3 675 RC #26 (Luisella)
2015 KTM RC 390 Cup
idahomike is offline  
post #3 of 8 (permalink) Old 04-26-2016, 01:11 AM Thread Starter
Established Member
 
iwannagofast's Avatar
 
Join Date: Oct 2015
Location: Australia
Posts: 177
New Site Garage
Gave moto technica a call and a common issue is the clutch starter kit. Waiting to hear back may be covered under warranty.


I would rather them look at it a pull it apart then me as i will probably cause more issues
iwannagofast is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 04-26-2016, 01:30 AM
Senior Member
 
idahomike's Avatar
 
Join Date: Jan 2012
Location: Las Vegas, NV
Posts: 265
Send a message via Skype™ to idahomike
Quote:
Originally Posted by iwannagofast View Post
Gave moto technica a call and a common issue is the clutch starter kit. Waiting to hear back may be covered under warranty.


I would rather them look at it a pull it apart then me as i will probably cause more issues
Please post the solution when it's found so we can learn from your experience.

Life Is Short, Eat Dessert First!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2007 Ninja 650R Candy Plasma Blue (Blue Thing) -SOLD
2013 F3 675 Red/Silver (Velocita) -SOLD
2014 899 Panigale Red (John Wayne)
2016 F3 675 RC #26 (Luisella)
2015 KTM RC 390 Cup
idahomike is offline  
post #5 of 8 (permalink) Old 04-26-2016, 03:21 AM Thread Starter
Established Member
 
iwannagofast's Avatar
 
Join Date: Oct 2015
Location: Australia
Posts: 177
New Site Garage
Quote:
Originally Posted by idahomike View Post
Please post the solution when it's found so we can learn from your experience.
Will do. Didnt hear back from them today so i will call again tomorrow and organise to get the bike to them in the coming week.
iwannagofast is offline  
post #6 of 8 (permalink) Old 04-26-2016, 03:10 PM
Senior Member
 
revhead1957's Avatar
 
Join Date: Apr 2011
Location: Brisbane, Australia
Posts: 1,596
Bad spark plugs will also throw that error.
revhead1957 is offline  
post #7 of 8 (permalink) Old 06-01-2016, 08:59 PM
New Member
 
voy333's Avatar
 
Join Date: Aug 2014
Location: NYC
Posts: 23
Got same error similar scenario tried to start her today took multiple tries then coil 2 error came up ... any closure on the problem ? Damn I just got that bike I know it ain't gonna be reliable like my cbr but come on ! =]

"Adding power makes you faster on the straights. Subtracting weight makes you faster everywhere" Colin Chapman, founder of Lotus cars
voy333 is offline  
post #8 of 8 (permalink) Old 06-09-2016, 08:20 PM
New Member
 
voy333's Avatar
 
Join Date: Aug 2014
Location: NYC
Posts: 23
spoke with the head mechanic of my local MV dealer and just from me describing the issue he said 2 things - one was make sure the battery is in the top notch condition otherwise you gonna see whole bunch of irrelevant to what may be the problem error codes ... another was to check out the spark plugs - he was saying how people "winterize" the bikes by going to the garage and barely starting them letting them run only few minutes. He went on explaining how BAD for the bike that is I do not remember all but basically he was saying that the bike never gets to an operating temperature and the spark plugs get dirty with every start ... also I'm surely repeating what has been said over here but just keep the battery on a "tender". When I bought the bike I was paranoid cuz I saw the ignition coil 2 error as well and she would not fire upright away ... I finally rode her for ... idk 40miles or so, plugged the tender and now she fires right up ! just like my inline 4 jap :P

"Adding power makes you faster on the straights. Subtracting weight makes you faster everywhere" Colin Chapman, founder of Lotus cars
voy333 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome