F3: Gear position wrong - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 02-10-2016, 10:28 AM Thread Starter
Senior Member
 
Join Date: May 2014
Location: Pennsylvania
Posts: 468
F3: Gear position wrong

I noticed this a while ago. The gear indicated on the dash would switch back and forth between gears even though I wasn't shifting. I originally thought it was because I did some quick down shifting or something (at the track) and the bike was still trying to register the proper gear. Anyways I went on a subtle street ride to where I could actually pay attention to the dash. If I was maintenance or slightly on the throttle it would display back and forth between 2 gears. From closed to wide open throttle the display behavior changed from completely wrong to accurate. Makes me think it's an electrical or connection issue. Anyone else had this issue?
JerryJoose is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 02-10-2016, 11:01 AM
Senior Member
 
jimboF4's Avatar
 
Join Date: Sep 2007
Location: North Somerset, England
Posts: 1,511
One of the most common faults, warranty issue, your dealer should be aware, contact them.

jimboF4

in the garage: 2001 F4 750 1+1, 2005 Brutale 910S Carbon, 2007 Brutale 910R, 2009 F41000R, 2013 Brutale 800, 2015 Turismo Veloce 800,1976 Triumph T140D Bonneville, 1976 Honda CB400F2.
jimboF4 is offline  
post #3 of 17 (permalink) Old 02-10-2016, 04:37 PM
Senior Member
 
idahomike's Avatar
 
Join Date: Jan 2012
Location: Las Vegas, NV
Posts: 265
Send a message via Skype™ to idahomike
Quote:
Originally Posted by JerryJoose View Post
I noticed this a while ago. The gear indicated on the dash would switch back and forth between gears even though I wasn't shifting. I originally thought it was because I did some quick down shifting or something (at the track) and the bike was still trying to register the proper gear. Anyways I went on a subtle street ride to where I could actually pay attention to the dash. If I was maintenance or slightly on the throttle it would display back and forth between 2 gears. From closed to wide open throttle the display behavior changed from completely wrong to accurate. Makes me think it's an electrical or connection issue. Anyone else had this issue?
Sensor should be replaced under warranty. Completely new design.
Attached Images
 

Life Is Short, Eat Dessert First!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2007 Ninja 650R Candy Plasma Blue (Blue Thing) -SOLD
2013 F3 675 Red/Silver (Velocita) -SOLD
2014 899 Panigale Red (John Wayne)
2016 F3 675 RC #26 (Luisella)
2015 KTM RC 390 Cup
idahomike is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 02-10-2016, 05:56 PM
New Member
 
Join Date: Nov 2014
Location: Brisbane, Australia
Posts: 42
I'm having similar problems with my F3 675. I've hit a false neutral between 4th and 5th gear while quickshifting (gulp). Since then occasionally my green neutral light comes up on the screen when shifting between 4th and 5th even when it is in 5th gear. Last time this was followed by the orange "engine malfunction" light going on. I slowed down ready to stop the bike but it turned off again about a minute later.

And my bike is no longer under warranty.

2013 MV Agusta F3 675
2002 Ducati 998R

Aussie F3 is offline  
post #5 of 17 (permalink) Old 02-11-2016, 03:59 AM
Senior Member
 
Wildfire's Avatar
 
Join Date: Mar 2014
Location: London, UK
Posts: 465
Have a chat with your local dealer and see if they can source and fit you one of the new units for a reasonable fee.

Mine was replaced under warranty, it used to be fine until 4th then it could be in 4-6 depending on what mood it was in. New one is totally new and works really well.

Last edited by Wildfire; 02-11-2016 at 04:01 AM.
Wildfire is offline  
post #6 of 17 (permalink) Old 02-11-2016, 07:55 AM Thread Starter
Senior Member
 
Join Date: May 2014
Location: Pennsylvania
Posts: 468
Thanks you guys. I just moved not long ago and the closest dealer is about 2 hours away now. It was just at the dealer for a couple of months before I moved to fix sprag clutch, rear brake, and throttle housing. I had completely forgot about the gear thing. I'll call and see if they can just send me the sensor under warranty without diagnostics
JerryJoose is offline  
post #7 of 17 (permalink) Old 03-22-2016, 04:08 AM
Established Member
 
2wheelsagain's Avatar
 
Join Date: Mar 2016
Location: Eastern Australia
Posts: 95
I just picked up my 2013 B3 800 today (private sale) and on the 250km ride home I noticed 6th wasn't showing although I definitely was in 6th.
My bike is out of warranty so any idea of the replacement part cost? I could live with it until the 12000km service. At least I now know it's nothing major.

My Current Bikes
2014 VFR1200F ~ How Fast Do You Want To Tour?
2013 B3 800 ~ Naked Foolishness!
2wheelsagain is offline  
post #8 of 17 (permalink) Old 03-22-2016, 04:31 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Quote:
Originally Posted by 2wheelsagain View Post
I just picked up my 2013 B3 800 today (private sale) and on the 250km ride home I noticed 6th wasn't showing although I definitely was in 6th.
My bike is out of warranty so any idea of the replacement part cost? I could live with it until the 12000km service. At least I now know it's nothing major.
Price check on Star Twin Tradings website mate - http://shop.startwintrading.com/en/p...tric-system--7

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #9 of 17 (permalink) Old 03-22-2016, 04:38 AM
Established Member
 
2wheelsagain's Avatar
 
Join Date: Mar 2016
Location: Eastern Australia
Posts: 95
Quote:
Originally Posted by Donsy View Post
Price check on Star Twin Tradings website mate - http://shop.startwintrading.com/en/p...tric-system--7
Thanks mate. I'll live with it for now.
Unsure why original owner didn't do it under warranty. He did battery and sprag clutch.

My Current Bikes
2014 VFR1200F ~ How Fast Do You Want To Tour?
2013 B3 800 ~ Naked Foolishness!
2wheelsagain is offline  
post #10 of 17 (permalink) Old 03-22-2016, 05:32 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Yeah I can't remember too well, but I though it was a recall item, I might be wrong and the other guys on here might know better. Enjoy the ride mate. Download manuals from my site too, always handy.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome