R&G Radiator Guard for Brutale 675 - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-18-2016, 11:12 PM Thread Starter
New Member
 
Join Date: Oct 2015
Posts: 34
R&G Radiator Guard for Brutale 675

Hi guys, my second post here in this forum.

I read in this forum that some members were having difficulties to fit the R&G radiator guard that it needed to be modified to fit properly. Before I make another mistake of ordering the part which might not fit, I just want to know whether anyone who has the Brutale 675 has any experience with their R&G radiator guard fitment.

I rang Radguard Australia and has been told they don't make radiator guard for Brutale.

thanks
flexi is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-19-2016, 02:00 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Since you are speaking to Al at Design Corse already, might as well ask him about the R&G guards - https://www.designcorse.com/collecti...ant=4231663809
I know quite a few guys uses them on other models and they come highly recommended.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #3 of 4 (permalink) Old 01-19-2016, 02:26 AM
Senior Member
 
jimboF4's Avatar
 
Join Date: Sep 2007
Location: North Somerset, England
Posts: 1,511
HiFlexi and welcome,
I fitted an R & G rad guard to my 2013 Brutale 800, fitted straight on no hassle at all.

jimboF4

in the garage: 2001 F4 750 1+1, 2005 Brutale 910S Carbon, 2007 Brutale 910R, 2009 F41000R, 2013 Brutale 800, 2015 Turismo Veloce 800,1976 Triumph T140D Bonneville, 1976 Honda CB400F2.
jimboF4 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 01-19-2016, 02:40 AM
Established Member
 
r6ymy's Avatar
 
Join Date: Sep 2015
Location: Witney, Oxfordshire
Posts: 189
I fitted one to my Turismo Veloce, I think it's the same fitting, went on easily. Only problem I've had is that the black paint has gone in the bottom centre of the guard after a couple of wet rides leaving a silver patch. Have given it a quick spray with a can, will see if it lasts.

Neville
Turismo Veloce
r6ymy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome