whole bunch of issues! - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 34 (permalink) Old 09-04-2015, 09:46 PM Thread Starter
New Member
 
spikespiegel's Avatar
 
Join Date: Sep 2014
Location: California
Posts: 33
whole bunch of issues!

Hey guys, at 2000 miles on the Rivale now. Issues i've had in chronological order:

1) Intermittent stalling by 300 miles: fixed by software update
2) loose/floppy right mirror by 1000 miles: tightening it by myself didn't help, so had dealer do it, fixed
3) starting problems; wont start on first crank (1500 mile mark). 2-3 tries now by 2000 mile mark. Going to take it to dealer as the suspect is sprag clutch
4) key stuck in ignition by 2000 mile mark. Key comes out of ignition but it wont turn towards ignition or lock. So can't start bike at ALL. Totally messed up issue. Going to take it to dealer for this issue as well.

QC is a joke for Italian machinery. Just thought i'd share these issues to see if anyone else is in the same boat. Never had so many issues on german/japanese bikes. Love riding the rivale, but the problems, not so much! My feedback so far!
spikespiegel is offline  
Sponsored Links
Advertisement
 
post #2 of 34 (permalink) Old 09-04-2015, 10:21 PM
Senior Member
 
TheX's Avatar
 
Join Date: Feb 2015
Location: Austin Texas USA
Posts: 445
I've had my share on my Rivale as well, but things seem better now.

At least your clutch basket didn't do this. Left me on the side of the road for hours.


Do something today that your future self will thank you for.
TheX is offline  
post #3 of 34 (permalink) Old 09-05-2015, 01:24 AM Thread Starter
New Member
 
spikespiegel's Avatar
 
Join Date: Sep 2014
Location: California
Posts: 33
bummer. Lets hope the dealer takes care of it cause "parts" need to be ordered. Aii. Should have known what i was getting into buying Italian
spikespiegel is offline  
Sponsored Links
Advertisement
 
post #4 of 34 (permalink) Old 09-12-2015, 01:36 PM Thread Starter
New Member
 
spikespiegel's Avatar
 
Join Date: Sep 2014
Location: California
Posts: 33
one more issue to add. Apparently the gas tank expanded due to ethanol in California gas! the good news? MV is fixing ALL the issues including a new gas tank, so i'm happy. A few weeks without the bike, but thanks to my dealer (and MV)i should be sorted soon.
spikespiegel is offline  
post #5 of 34 (permalink) Old 09-12-2015, 04:16 PM
Senior Member
 
crash2much's Avatar
 
Join Date: Jan 2008
Location: Escondido
Posts: 1,155
4,900 miles on my 2014 Rivale. Here is the long list of issues I have encountered:

1) Floppy mirrors - replaced under warranty.
2) Fuel tank expanded (just like about every other mfg. with plastic tanks) - replaced under warranty
3) 1,400 miles - rear tire was bad
4) 2,500 miles - rear tire was bad
5) 2,700 miles - front tire was bad
6) 3,900 miles - rear tire was bad
7) 4,800 miles - front & rear tire was bad

Way too many issues. What a piece of crap!!
crash2much is offline  
post #6 of 34 (permalink) Old 09-12-2015, 04:57 PM
Senior Member
 
TheX's Avatar
 
Join Date: Feb 2015
Location: Austin Texas USA
Posts: 445
I hope you guys are getting the bigger tank. Getting fuel light at 70 miles sucks. I get the light at ~105 now.

Do something today that your future self will thank you for.
TheX is offline  
post #7 of 34 (permalink) Old 09-12-2015, 05:13 PM
Senior Member
 
nneal12's Avatar
 
Join Date: Feb 2014
Location: Southern California
Posts: 560
Quote:
Originally Posted by crash2much View Post
4,900 miles on my 2014 Rivale. Here is the long list of issues I have encountered:

1) Floppy mirrors - replaced under warranty.
2) Fuel tank expanded (just like about every other mfg. with plastic tanks) - replaced under warranty
3) 1,400 miles - rear tire was bad
4) 2,500 miles - rear tire was bad
5) 2,700 miles - front tire was bad
6) 3,900 miles - rear tire was bad
7) 4,800 miles - front & rear tire was bad

Way too many issues. What a piece of crap!!
Out of curiosity, what ended up causing the tires to fail? I'm assuming there was a bike issue since you list it as an MV problem.
nneal12 is offline  
post #8 of 34 (permalink) Old 09-12-2015, 05:31 PM
Senior Member
 
crash2much's Avatar
 
Join Date: Jan 2008
Location: Escondido
Posts: 1,155
Honestly, the fuel range is not a problem for me. When I ride this crazy contraption MV calls a motorcycle, after about 50 or 60 miles I am so exhausted, I need a break anyway.
I think the Rivale is engineered wrong. I feel it is a problem with the chassis/handling:

1) It accelerates very early out of the corner and incredibly hard, many times the rear wheel looses grip.
2) It carries too much corner speed at scary lean angles.
3) Going into the corners the brakes come on extremely late and strongly all the way to the apex. Often times the rear wheel is squirming and sliding at the same time.

No other of my many bikes ever exhibited these traits so severely - therefore, I conclude that MV's engineers designed this bike all wrong.
I will send the factory a letter and complain about the Rivale's excessive tire use.
crash2much is offline  
post #9 of 34 (permalink) Old 09-12-2015, 06:12 PM
Senior Member
 
GREGOSTINI's Avatar
 
Join Date: Aug 2012
Location: Perth, Australia
Posts: 895
It sounds like the nut holding the handlebars is loose, Balz.

We're all here, but we're not all there.
GREGOSTINI is offline  
post #10 of 34 (permalink) Old 09-12-2015, 06:56 PM
Senior Member
 
crash2much's Avatar
 
Join Date: Jan 2008
Location: Escondido
Posts: 1,155
Hmmmm, good point. I will check that. Do you know the torque spec for that?
crash2much is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome