Turn Signal problem anyome? possible relay? - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 05-28-2007, 12:10 AM Thread Starter
Senior Member
 
mv2envy's Avatar
 
Join Date: May 2007
Location: Reseda, California
Posts: 5,824
Turn Signal problem anyone? possible relay?

hey guys,

my blinkers dont work, i just got the bike back from pro italia, they said they had fixed it, and on the way home, it stopped working again, the blinkers just come on and stay on, PI said that they changed the blinker relay, it was bad, is it possible that the new one went bad too? anyone els ever have blinker problems? does anyone know where the blinker relay is located?

Last edited by mv2envy; 05-28-2007 at 01:26 AM.
mv2envy is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 05-28-2007, 12:19 AM
Established Member
 
weskro's Avatar
 
Join Date: Apr 2007
Posts: 140
I had the same problem the other day. I went to the track and I had the dealer take off my rear blinkers. When they put them back on I noticed that just the front light was on on the right side when I turned my blinker on.

I figured that they did not hook the plug the wires in all the way so I lifted up the seat and traced the wires back. There are 3 of them that have quick connectors so I just traced the one down and unplugged the working one and that produced the same problem (light staying on). I plugged it back in and it worked so I did the same to the non-working one and it worked.

So give that a try....

-Wesley
weskro is offline  
post #3 of 18 (permalink) Old 05-28-2007, 01:20 AM Thread Starter
Senior Member
 
mv2envy's Avatar
 
Join Date: May 2007
Location: Reseda, California
Posts: 5,824
none of mine work, needless to say i have the clear alternatives intergrated tail light.
mv2envy is offline  
post #4 of 18 (permalink) Old 05-28-2007, 03:20 AM
Senior Member
 
Some Guy's Avatar
 
Join Date: Sep 2006
Location: NY
Posts: 822
mine worked sporadically, and then just stopped working all together. Oddly enough, these bikes are still running fuses in the blinkers, and that was the cause of my problem. I was pretty astounded that MV still runs fuses as Harley Davidson, the crotchety old man of innovators, has been using a turn signal module with no fuses since 1988....you gotta love italian engineering!

"Don't mistake kindness for flatulence, bitchez."


07 Brutale 910r

95 Buell S2 Thunderbolt
Some Guy is offline  
post #5 of 18 (permalink) Old 05-28-2007, 06:51 AM
Senior Member
 
Matty's Avatar
 
Join Date: Jul 2005
Location: Manchester Connecticut
Posts: 1,331
Send a message via AIM to Matty
if you had taken off the front nose faring i would take it of again and put it back on. The front blinkers are not attached by any wires just a contact point. My left side stopped working yesterday and realized that i must have not put the nose faring back on properly.

Matty
Matty is offline  
post #6 of 18 (permalink) Old 05-28-2007, 09:13 AM Thread Starter
Senior Member
 
mv2envy's Avatar
 
Join Date: May 2007
Location: Reseda, California
Posts: 5,824
no my nose fairing is on properly, pro italia put it on. ok, so ill check the fuse, but doesnt anyone know where the blinker relay is located?
mv2envy is offline  
post #7 of 18 (permalink) Old 05-28-2007, 09:55 AM
Established Member
 
NFLPATS's Avatar
 
Join Date: Jul 2006
Location: Las Vegas
Posts: 97
blinker relay is under the left side air scoop. You have to remove the front nose to get to it.
NFLPATS is offline  
post #8 of 18 (permalink) Old 05-28-2007, 12:53 PM
Senior Member
 
awiner's Avatar
 
Join Date: Oct 2005
Location: Southern California
Posts: 375
Quote:
Originally Posted by mv2envy
no my nose fairing is on properly, pro italia put it on. ok, so ill check the fuse, but doesnt anyone know where the blinker relay is located?
On the F4, the blinker relay is located behind the left side panel. It is in the group of 3 relays that mount to the frame on a u bracket. The relay you are interested in is located in the middle.

After I added the hyper lights as turning indicators in the rear cowl, I actually bought a new two pole varible load relay for my bike to replace the stock unit which always seemed to have issues with aftermarket LED units. The relay I bought is made to work with LED as well as the normal light bulbs.

Last edited by awiner; 05-28-2007 at 12:57 PM.
awiner is offline  
post #9 of 18 (permalink) Old 05-28-2007, 05:46 PM Thread Starter
Senior Member
 
mv2envy's Avatar
 
Join Date: May 2007
Location: Reseda, California
Posts: 5,824
Quote:
Originally Posted by awiner
On the F4, the blinker relay is located behind the left side panel. It is in the group of 3 relays that mount to the frame on a u bracket. The relay you are interested in is located in the middle.

After I added the hyper lights as turning indicators in the rear cowl, I actually bought a new two pole varible load relay for my bike to replace the stock unit which always seemed to have issues with aftermarket LED units. The relay I bought is made to work with LED as well as the normal light bulbs.
could you please pm me where i can find one of those relays? or if you could get me one, ill pay you, thanx
mv2envy is offline  
post #10 of 18 (permalink) Old 05-28-2007, 06:10 PM
Senior Member
 
Matty's Avatar
 
Join Date: Jul 2005
Location: Manchester Connecticut
Posts: 1,331
Send a message via AIM to Matty
any auto parts place should have them....i did the same for my bike....i do not remember the part number though but if ya search the site im sure you can find it

Matty
Matty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome