My F4 died on me - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 32 (permalink) Old 03-16-2014, 05:10 PM Thread Starter
New Member
 
Join Date: Aug 2012
Location: tallahassee fl
Posts: 50
My F4 died on me

I need a little help trouble shooting my 07 F4. Took the MV out earlier today since there was decent weather for a change. Well cruising along, maybe 20 minutes into my ride, I went to give it more throttle and everything shut down and was completely dead. Safely on the side of the road I had no lights, dash or engine power. While doing a quick troubleshooting I noticed that when I turned the key on, I got no lights or power but I could hear the fuel pump prime. Since I was riding at the time, I ruled out the battery and was thinking ECU. Any help will be greatly appreciated.
leww1 is offline  
Sponsored Links
Advertisement
 
post #2 of 32 (permalink) Old 03-16-2014, 07:09 PM
Banned
 
Join Date: Sep 2013
Posts: 676
Blown fuse.
Dana Kincaid is offline  
post #3 of 32 (permalink) Old 03-16-2014, 07:15 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,813
Send a message via Skype™ to silentservice703
Agreed

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #4 of 32 (permalink) Old 03-16-2014, 10:12 PM Thread Starter
New Member
 
Join Date: Aug 2012
Location: tallahassee fl
Posts: 50
Thanks. It was a fuse. Now it's time to find the cause of it.

Sent from Motorcycle.com Free App
leww1 is offline  
post #5 of 32 (permalink) Old 03-16-2014, 10:43 PM
Senior Member
 
wnehme's Avatar
 
Join Date: Dec 2005
Location: Sydney Australia
Posts: 1,992
New Site Garage
Was it the 40 amp fuse?


Sent from Motorcycle.com App
wnehme is offline  
post #6 of 32 (permalink) Old 03-17-2014, 02:04 AM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,798
Send a message via Skype™ to theknurl
Quote:
Originally Posted by wnehme View Post
Was it the 40 amp fuse?
Wissam;
don't think so, the pump primes....

I hate electrical stuff.....

Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is online now  
post #7 of 32 (permalink) Old 03-17-2014, 06:28 AM Thread Starter
New Member
 
Join Date: Aug 2012
Location: tallahassee fl
Posts: 50
It was the 15 amp

Sent from Motorcycle.com Free App
leww1 is offline  
post #8 of 32 (permalink) Old 03-17-2014, 07:27 AM
Senior Member
 
EVO Chris's Avatar
 
Join Date: Apr 2006
Location: Rochester Kent UK
Posts: 880
New Site Garage
Any luck finding the problem, had an issue once with the starter solenoid 40 amp fuse, it was full of water and corroded, may be worth checking whilst you are there.

MV F4 750 EVO3 2003
MV Brutale 910s 2007
Honda VFR800 1998
Honda MBX 125 FE 1983
F4 Agusta mini moto replica
Chinese Quadbike made of peanut butter (crunchy).
EVO Chris is offline  
post #9 of 32 (permalink) Old 03-17-2014, 11:55 AM Thread Starter
New Member
 
Join Date: Aug 2012
Location: tallahassee fl
Posts: 50
Quote:
Originally Posted by EVO Chris View Post
Any luck finding the problem, had an issue once with the starter solenoid 40 amp fuse, it was full of water and corroded, may be worth checking whilst you are there.
Haven't checked it yet. Plan on going thru the wires tonight
leww1 is offline  
post #10 of 32 (permalink) Old 03-17-2014, 06:45 PM
New Member
 
Paors's Avatar
 
Join Date: Apr 2013
Location: Vancouver, BC
Posts: 62
Send a message via Skype™ to Paors
Any chance you ran out of fuel recently?

'13 F4 RR
'11 BMW R1200RT
'12 Aprilia Dorsoduro 1200 - sold
'08 BMW R1200GS Adv - sold
'10 HD XR1200 - sold
'10 Blata Ultima
Paors is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome