Speedo only reads 0 and speed sensor ok - MVAgusta.net
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 49 (permalink) Old 01-03-2014, 02:31 PM Thread Starter
Established Member
 
NICO312RR's Avatar
 
Join Date: Sep 2013
Location: Montevideo, Uruguay, South America
Posts: 192
New Site Garage
Speedo only reads 0 and speed sensor ok

Hi to all. On my 1078 312RR, my speedo stopped working, everything else in the dash works fine but my speedometer stays at "zero" and the tripometer also freezed. I took out the sensor at the sproket cover and run the test that the manual says and it turned out ok so the question is... whats next?? wiring issue??
NICO312RR is offline  
Sponsored Links
Advertisement
 
post #2 of 49 (permalink) Old 01-03-2014, 08:21 PM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
Checked the plug behind the speedo Nicolas ?

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #3 of 49 (permalink) Old 01-04-2014, 05:16 AM Thread Starter
Established Member
 
NICO312RR's Avatar
 
Join Date: Sep 2013
Location: Montevideo, Uruguay, South America
Posts: 192
New Site Garage
Quote:
Originally Posted by Donsy View Post
Checked the plug behind the speedo Nicolas ?
NO I HAVE NOT CHECKED THAT YET! you think it might de unpluged?? everything else but the speedo works fine!
NICO312RR is offline  
post #4 of 49 (permalink) Old 01-06-2014, 06:15 AM Thread Starter
Established Member
 
NICO312RR's Avatar
 
Join Date: Sep 2013
Location: Montevideo, Uruguay, South America
Posts: 192
New Site Garage
Quote:
Originally Posted by Donsy View Post
Checked the plug behind the speedo Nicolas ?
Chacked on the plug, disconected it and connected it back but still no luck. This is pretty weird! the thing was working fine and one day it just stoped!
is there anything else I could try?
NICO312RR is offline  
post #5 of 49 (permalink) Old 01-06-2014, 07:33 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,674
Send a message via Skype™ to silentservice703
Yes, go to the F4 312R Shop manual and get into the electrical diagram. Identify what is not working and follow the wiring diagram to identify the source of the issue.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #6 of 49 (permalink) Old 01-08-2014, 01:37 PM Thread Starter
Established Member
 
NICO312RR's Avatar
 
Join Date: Sep 2013
Location: Montevideo, Uruguay, South America
Posts: 192
New Site Garage
Quote:
Originally Posted by silentservice703 View Post
Yes, go to the F4 312R Shop manual and get into the electrical diagram. Identify what is not working and follow the wiring diagram to identify the source of the issue.
guess im gonna have to do that. not an easy task
NICO312RR is offline  
post #7 of 49 (permalink) Old 01-08-2014, 03:15 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,674
Send a message via Skype™ to silentservice703
Patience is a virtue when tracing electrical issues. Be methodical and know exactly what is and is not working.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #8 of 49 (permalink) Old 01-09-2014, 10:32 AM Thread Starter
Established Member
 
NICO312RR's Avatar
 
Join Date: Sep 2013
Location: Montevideo, Uruguay, South America
Posts: 192
New Site Garage
Quote:
Originally Posted by silentservice703 View Post
Patience is a virtue when tracing electrical issues. Be methodical and know exactly what is and is not working.
right at the moment everything works but the speedometer, it reads ZERO all the time. I`m guessing my speed based on the rpm and gears...
First thing I did was taking the speed sensor off the sproket cover, tested it and came back ok... then I took appart the spedometer and cleaned it up with a dry cloth, replaced the bulbs behind the rpm tach (one had gone out) and cleaned the conectors behind the speedo and also the one at that connects the speed sensor at the sproket area. I put everything back together but speedo won`t work
NICO312RR is offline  
post #9 of 49 (permalink) Old 01-09-2014, 04:13 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,674
Send a message via Skype™ to silentservice703
Argh. Nico, if I have some time this weekend, I'll see what I can find.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #10 of 49 (permalink) Old 01-09-2014, 05:35 PM Thread Starter
Established Member
 
NICO312RR's Avatar
 
Join Date: Sep 2013
Location: Montevideo, Uruguay, South America
Posts: 192
New Site Garage
Quote:
Originally Posted by silentservice703 View Post
Argh. Nico, if I have some time this weekend, I'll see what I can find.
roght on!!
NICO312RR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome