2005 MV Agusta F4 1000 fueling problem/surges - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 08-12-2013, 08:35 PM Thread Starter
New Member
 
Join Date: Sep 2012
Posts: 33
2005 MV Agusta F4 1000 fueling problem/surges

I own a 2005 MV Agusta F4 1000$ with 20,000 miles. I've put 6000 of those miles on the bike. I've been diligent with the maintenance and have taken it to the dealer for basically everything. I had the major 15,000 mile service a few months after I bought it. I haven't done any crazy modifications. I've added the Muzzy fans and that's about it. Recently, the dealer replaced a fuel injector relay.

Anyway, my bike starts up no problem. It's when I start to ride that things get nightmarish. Idling at a light, she sounds like an old VW Bug that is about to cut out at any minute. Some times she dies, sometimes she doesn't. One thing for sure is that I have to feather the clutch and rev the engine to get her going. When I'm on the highway, if I open the throttle nothing happens for about 5 seconds and then I'll be hit with a surge. It doesn't matter what gear I'm in. Even with a steady throttle, the bike will surge. It feels as though it's getting a lot of fuel and then not enough. With this problem, turns become things to be avoided because I'm afraid a surge will kick in while I have her leaned over. I've tried fuel additives, changing gas stations, all to no avail. I live in a pretty humid and hot area. Lately, it's been 89 degree but with the humidity it feels like 95 degree. I really hope you guys can shed some light on the situation. I'm very frustrated and don't know if I can take it any more. I haven't had one trouble free ride yet. It's a pity, because she so beautiful to look at, but not to ride. Any ideas?
MVgofast is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 08-13-2013, 07:28 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,669
Send a message via Skype™ to silentservice703
First...where are you?
Second...do you have decent mechanical skills?
Third...can you check the TPS setting?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #3 of 18 (permalink) Old 08-13-2013, 09:06 AM Thread Starter
New Member
 
Join Date: Sep 2012
Posts: 33
I'm in South Florida. I have decent skills. I've never checked the TPS sensor. The dealer checked it though.
MVgofast is offline  
post #4 of 18 (permalink) Old 08-13-2013, 03:30 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,669
Send a message via Skype™ to silentservice703
Did this problem begin after the dealer replaced the fuel injector relay, or was it present before?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 18 (permalink) Old 08-13-2013, 04:08 PM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Have you changed the EBS relay?
CAG is offline  
post #6 of 18 (permalink) Old 08-13-2013, 08:48 PM Thread Starter
New Member
 
Join Date: Sep 2012
Posts: 33
I checked my records to be sure. They changed the EBS relay in June. It seemed to perform better for a few weeks. Three weeks ago, I had the gaskets around the gearshift, and clutch replaced because it was leaking a lot of oil. Since then it has been worse.
MVgofast is offline  
post #7 of 18 (permalink) Old 08-13-2013, 09:53 PM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 17,599
Send a message via Skype™ to esq'z me
You have a 16M ECU that requires very specific throttle body synch, TPS adjustment and idle CO% trim.

Did your dealer replace the plugs? with what kind? Can the tell you where the TPS is and what they set the CO % to?

The MV with 16M ECU is very sensitive to proper tune. I suspect that is all you are dealing with. Or perhaps a fuel filter that is in need pf replacement....that could be it as well.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, 2015 Indian Chieftain (Rita) my "low-n-slow", '70 Suzuki F50 (Baby Blue), 2018 Suzuki GSX-S750L8 (Susie Q)
esq'z me is online now  
post #8 of 18 (permalink) Old 08-13-2013, 10:50 PM Thread Starter
New Member
 
Join Date: Sep 2012
Posts: 33
I'm going to stop by the dealer tomorrow and see what they say. I'll let you guys know!
MVgofast is offline  
post #9 of 18 (permalink) Old 08-14-2013, 03:55 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,669
Send a message via Skype™ to silentservice703
Interesting, Ed, as I was thinking fuel filter, too.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #10 of 18 (permalink) Old 08-14-2013, 12:53 PM Thread Starter
New Member
 
Join Date: Sep 2012
Posts: 33
I changed the filter recently. The dealer suspects it may be a coil. We'll see. I hope it's something easy like a clogged filter...
MVgofast is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome