changing the battery problems - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-14-2013, 03:36 PM Thread Starter
New Member
 
kirduc's Avatar
 
Join Date: Dec 2011
Location: SERRES, GREECE
Posts: 40
changing the battery problems

hi you guys,

Today I took off the battery (odyssey pc301) because the bike didnt start (low voltage). after charging the battery for an hour with a ctek charger, I put it on the bike, turned the key on but the dash and fuel pump dint come on. the only dash lights that were on was the battery , light and oil indicator lights. Headlight and tailight were dead too. I already checked the fuses and they re ok. anyone with a remedy???

Kiriakos


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
f4r 312, xb9r, st4, st4s, m620s, 900ss, 888, rsv1000r, ktm520exc, ktm525exc, ktm620ls, ktm690exc, r25
kirduc is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-14-2013, 04:07 PM
Senior Member
 
The_castle's Avatar
 
Join Date: Nov 2007
Location: New Zealand
Posts: 7,346
Send a message via Skype™ to The_castle
Have you installed the battery with reverse polarity?

Positive cable to negative terminal / negative cable to positive terminal?

It ain't what you ride, it's the way you ride it.
The_castle is offline  
post #3 of 5 (permalink) Old 06-14-2013, 04:49 PM
Senior Member
 
gotojoe's Avatar
 
Join Date: Nov 2009
Location: Bellanagare, West Ireland 44 7875 299281
Posts: 9,932
Quote:
Originally Posted by kirduc View Post
hi you guys,

Today I took off the battery (odyssey pc301) because the bike didnt start (low voltage). after charging the battery for an hour with a ctek charger, I put it on the bike, turned the key on but the dash and fuel pump dint come on. the only dash lights that were on was the battery , light and oil indicator lights. Headlight and tailight were dead too. I already checked the fuses and they re ok. anyone with a remedy???

Kiriakos

I have an Odyssey on my bike..elcrappo..Would never buy another one. Not made in USA now made in Brazil ..QC gone down the chute...rubbish in my experience.

My Odyssey won't retain charge goes flat ..it's useless and I have maintained it correctly,

joe
gotojoe is offline  
post #4 of 5 (permalink) Old 06-14-2013, 06:36 PM
Senior Member
 
The_castle's Avatar
 
Join Date: Nov 2007
Location: New Zealand
Posts: 7,346
Send a message via Skype™ to The_castle
2013: A crap Odyssey.
Attached Images
 

It ain't what you ride, it's the way you ride it.
The_castle is offline  
post #5 of 5 (permalink) Old 06-15-2013, 04:52 AM Thread Starter
New Member
 
kirduc's Avatar
 
Join Date: Dec 2011
Location: SERRES, GREECE
Posts: 40
Quote:
Originally Posted by The_castle View Post
2013: A crap Odyssey.

odyssey IS CRAP...... The problem appears to be that the ecu didnt have the required voltage to activate ecu..... put back my old yuasa from my ktm 690 and started just fine.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
f4r 312, xb9r, st4, st4s, m620s, 900ss, 888, rsv1000r, ktm520exc, ktm525exc, ktm620ls, ktm690exc, r25
kirduc is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome