Electrical issue please HELP! - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 03-24-2013, 11:49 PM Thread Starter
New Member
 
Join Date: Apr 2011
Location: Minnesota
Posts: 8
Question Electrical issue please HELP!

So after pulling my 2007 f4 out of storage, I noticed I forgot to remove the battery. Naturally it was dead and wouldn't take a charge. So I bought a new battery and put it in and turned the key...and nothing happened. No lights, nothing. Idk where to even start looking or what it could possibly be.

Any ideas???

And yes it is the correct battery and the new battery is good. Had it tested.
MV_Rookie_128 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 03-25-2013, 12:12 AM
MVAgusta.net Sponsor
 
mitchy's Avatar
 
Join Date: Feb 2010
Location: Gold Coast, Australia.
Posts: 4,904
New Site Garage
Send a message via Skype™ to mitchy
Sorry,I have to ask is the battery connected properly.Meaning positive/negative terminals are correct.Have you checked the fuses?Is the fuel pump going through it's test cycle when you turn the ignition on,or is that dead too.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Bike- F4 1078.
Work.Email & Paypal.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Work Phone (+61)0755244655
Facebook- Mitch Covington
Mobile-0423041326

Last edited by mitchy; 03-25-2013 at 12:20 AM.
mitchy is offline  
post #3 of 14 (permalink) Old 03-25-2013, 12:46 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,054
New Site Garage
+10 on what Mitch said. Then when you finished correcting the error. Replace the 40A fuse on the Starter solenoid and hope you didn't blow the diode.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #4 of 14 (permalink) Old 03-25-2013, 04:10 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,669
Send a message via Skype™ to silentservice703
Well, Rookie, as a friend once said to me: "Check what you did last, before the problem, that's what you need to fix."

It is likely that you installed the battery with its polarity reversed. There are many threads on the subject, and many people who continue to do this. The battery is supposed to be installed on its side with the negative terminal forward. Batteries for this bike will install quite nicely with the terminals up and the negative at the rear leading to connection at the wrong poles.

Hopefully, as Mitch and Dons have mentioned, you just need to pull the battery and install it correctly and the main fuse protected all else.

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #5 of 14 (permalink) Old 03-25-2013, 08:18 AM Thread Starter
New Member
 
Join Date: Apr 2011
Location: Minnesota
Posts: 8
Battery is installed properly. Positive in the back. Neg in front. And no the fuel pump doesn't turn on. I turn the key and its as if I didn't. No lights. No noises. Nothin. Idk how anything could have blown or anything cuz I started it in January and ran just fine. Now I swapped batteries and nothing works.

If its the fuses, where are they located and I'm guessing if they are bad I should expect to have to order them online?
MV_Rookie_128 is offline  
post #6 of 14 (permalink) Old 03-25-2013, 10:22 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,669
Send a message via Skype™ to silentservice703
Did you get all the wiring hooked up?

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #7 of 14 (permalink) Old 03-25-2013, 02:33 PM
Established Member
 
trickydicky's Avatar
 
Join Date: May 2008
Location: East Yorkshire UK
Posts: 247
New Site Garage
I know on my 2002 750 there are 2 wires on the negative side and when I changed my battery one of the leads dropped out of sight which is very easy for it to do.
trickydicky is offline  
post #8 of 14 (permalink) Old 03-25-2013, 02:57 PM
Senior Member
 
Rommeld's Avatar
 
Join Date: Feb 2011
Posts: 304
The main fuse is in the box on the left side of your bike when you are sitting on the bike. Just remove the left main fairing panel and you will see it left of your tank.

Isn't the F4 the most beautiful bike you have ever seen?
Rommeld is offline  
post #9 of 14 (permalink) Old 03-25-2013, 03:13 PM
MVAgusta.net Sponsor
 
mitchy's Avatar
 
Join Date: Feb 2010
Location: Gold Coast, Australia.
Posts: 4,904
New Site Garage
Send a message via Skype™ to mitchy
The fuses are a standard mini blade fuse.Any Auto shop will have them.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Bike- F4 1078.
Work.Email & Paypal.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Work Phone (+61)0755244655
Facebook- Mitch Covington
Mobile-0423041326
mitchy is offline  
post #10 of 14 (permalink) Old 03-25-2013, 04:20 PM Thread Starter
New Member
 
Join Date: Apr 2011
Location: Minnesota
Posts: 8
2 negative 1 positive correct?
MV_Rookie_128 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome