NIWI Question - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-08-2011, 12:35 PM Thread Starter
New Member
 
nickinhouston's Avatar
 
Join Date: Jul 2011
Location: Houston, Texas
Posts: 43
NIWI Question

Hey I just joined this forum and sorry my first post is a help thread but I just bought an 08 312 and installed the MV brand NIWI . I didnt replace the impeller shaft seal and after the install I noticed coolant in my oil and the leak from the weep hole . Did I screw up big time or can I just change the seal and give it a fresh oil change . Thanks for any help
nickinhouston is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-08-2011, 03:54 PM
Established Member
 
billas f4's Avatar
 
Join Date: Jun 2011
Location: Guam, USA
Posts: 158
Is this what happens when you don't do the install right?

2003 749S
2008 F4 R312
billas f4 is offline  
post #3 of 8 (permalink) Old 07-08-2011, 04:17 PM Thread Starter
New Member
 
nickinhouston's Avatar
 
Join Date: Jul 2011
Location: Houston, Texas
Posts: 43
Im not sure if its because the NIWI creates more pressure and the seal couldn't hold but during the install I didn't mess with the seal , I just unscrewed the impeller from the shaft and put the new one on
nickinhouston is offline  
post #4 of 8 (permalink) Old 07-08-2011, 04:26 PM
Senior Member
 
cooper3309's Avatar
 
Join Date: Sep 2007
Location: Huron South Dakota
Posts: 1,389
I'd say change the seal and change the oil. It should be fine as long as you stop the leak.

Oh........ and welcome to the forum


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Take off your pants and jacket

01 750S W/1000R engine
01 Ducati 748 W/853 kit
03 Yamaha R1 (SOLD)
01 Kawasaki KX 125
88 Yamaha YSR 50
01 Yamaha R6
03 Suzuki DRZ pitbike
1982 Honda 110 atc
Yamaha PW50
1978 Honda 90 atc
2011 Yamaha Grizzly 700
2008 Yamaha Raptor 660
1975 Kawasaki G5 100
cooper3309 is offline  
post #5 of 8 (permalink) Old 07-08-2011, 04:32 PM Thread Starter
New Member
 
nickinhouston's Avatar
 
Join Date: Jul 2011
Location: Houston, Texas
Posts: 43
I'm picking up seals and oil tomorrow and will let you know the outcome
nickinhouston is offline  
post #6 of 8 (permalink) Old 07-09-2011, 01:57 PM Thread Starter
New Member
 
nickinhouston's Avatar
 
Join Date: Jul 2011
Location: Houston, Texas
Posts: 43
I changed both seals and all the O-rings on the water pump , changed out the oil and filter and everything is good NO LEAKS
nickinhouston is offline  
post #7 of 8 (permalink) Old 07-09-2011, 04:23 PM
Senior Member
 
cooper3309's Avatar
 
Join Date: Sep 2007
Location: Huron South Dakota
Posts: 1,389
Thumbs up

Awesome


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Take off your pants and jacket

01 750S W/1000R engine
01 Ducati 748 W/853 kit
03 Yamaha R1 (SOLD)
01 Kawasaki KX 125
88 Yamaha YSR 50
01 Yamaha R6
03 Suzuki DRZ pitbike
1982 Honda 110 atc
Yamaha PW50
1978 Honda 90 atc
2011 Yamaha Grizzly 700
2008 Yamaha Raptor 660
1975 Kawasaki G5 100
cooper3309 is offline  
post #8 of 8 (permalink) Old 07-09-2011, 07:15 PM
Established Member
 
billas f4's Avatar
 
Join Date: Jun 2011
Location: Guam, USA
Posts: 158
It's time to enjoy the ride.

2003 749S
2008 F4 R312
billas f4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome