water pump leaking? what do you think?? - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 07-26-2010, 01:48 PM Thread Starter
Senior Member
 
martosh79's Avatar
 
Join Date: Feb 2010
Location: Finland
Posts: 311
water pump leaking? what do you think??

Hello,

as I have mentioned in my earlier posts, I have had a few problems with my f4 1000R.

It went to its 6000km service 3-4 weeks ago and since then it has over heated by that I mean went up to 116 degrees.

Today when I was driving to work the oil light went on after 10 kilometers and the engine temperature was at 100 degrees.

I cold the engine at a gas station then drove 2 kilometers to work.

I called the service place and they told me to come today over there. When I arrived after my work over there they controlled my bike and everything was normal. Just when I was leaving I wanted to show them that the temperature goes high, so that they can see what can be done with it.

The service guy started the engine and at 100 degrees some leaking appeared and a few seconds later a huge amount of cooling liquid came from the bike. After we took all the body panels off we finally saw that it wasn't leaking from the overheating leaking pipe but from a bolt of the water pump.

Now the water pump is going to be repaired.

What do you think has to be done? Do they have to change the whole pump or just the plastic joints?

Has someone had the same kind of problem?

advice me and make me more intelligent

cheers
martosh
martosh79 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-26-2010, 07:29 PM
Senior Member
 
theknurl's Avatar
 
Join Date: Jul 2009
Location: Palos Verdes Est, SoCal, USA
Posts: 13,892
Send a message via Skype™ to theknurl
Smile

Martti;
at no time should a water pump bolt be leaking especially just after a service....

if the seal in the pump is bad. the leak is from behind the pump

did you have the HO water pump installed?

Hitcho73 did....
they didn't do it correctly and his bike overheated too

Noel-theknurl

Noel-theknurl

The Forum Curmudgeon
I'm not PC either
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R
'05 F4
ph. 310-414-7247 PST, GMT -8
PayPal;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Skype; theknurl
theknurl is offline  
post #3 of 9 (permalink) Old 07-27-2010, 04:24 AM
Senior Member
 
PP1098's Avatar
 
Join Date: Nov 2008
Posts: 332
Had the same problem with the 1078 i.e. coolant dripping from the bottom screw of the pump.
Do a search on my threads and you will find pictures as well.

Summary:

Inside the pump there is a 'rod' which I had to replace together with some washers. Easy fix, cheap parts from Vesuvio and problem gone now. Dont overfill the tank after replace, stay below the MIN level (my bike standing straight when cool, you can hardly see the liquid surface at the side-its low) and you ll be fine. Maybe its sth else with your bike this is my experience.

Rgds
Phil
PP1098 is offline  
post #4 of 9 (permalink) Old 07-27-2010, 04:25 AM
Senior Member
 
PP1098's Avatar
 
Join Date: Nov 2008
Posts: 332
http://www.mvagusta.net/forum/showthread.php?t=28568

this is the thread in January 10
PP1098 is offline  
post #5 of 9 (permalink) Old 07-27-2010, 07:30 AM Thread Starter
Senior Member
 
martosh79's Avatar
 
Join Date: Feb 2010
Location: Finland
Posts: 311
Hi,

I have everything OEM on it.

It just over heated after the service and now broke down.

They will replace it cos' on guarranty.


Quote:
Originally Posted by theknurl View Post
Martti;
at no time should a water pump bolt be leaking especially just after a service....

if the seal in the pump is bad. the leak is from behind the pump

did you have the HO water pump installed?

Hitcho73 did....
they didn't do it correctly and his bike overheated too

Noel-theknurl
martosh79 is offline  
post #6 of 9 (permalink) Old 07-27-2010, 07:32 AM Thread Starter
Senior Member
 
martosh79's Avatar
 
Join Date: Feb 2010
Location: Finland
Posts: 311
Tx for the thread.

We will see what is the problem with it after the service guy will have it taken appart.

We will see what we have to do, the importer in Finland has never had that kind of problem before.

I might later change it to a bigger pump but I will let the fix it before, when it will work I will eventualy change it.

Quote:
Originally Posted by PP1098 View Post
martosh79 is offline  
post #7 of 9 (permalink) Old 07-27-2010, 07:35 AM Thread Starter
Senior Member
 
martosh79's Avatar
 
Join Date: Feb 2010
Location: Finland
Posts: 311
It's now warm in here 88 degrees fahrenheit in the shadow. And when you are stuck in traffic it just overheats. Will see how it works after the new pump. But tx all for the responses
martosh79 is offline  
post #8 of 9 (permalink) Old 08-10-2010, 10:45 AM Thread Starter
Senior Member
 
martosh79's Avatar
 
Join Date: Feb 2010
Location: Finland
Posts: 311
Hi there,

my bike is still at the shop, they tried to change the joints in the pump but it doesn't help. Now they are waiting for a new water pump. At the same time they can check the engine and the covers because the oil light went on...

What else would you check on the bike at that same time? What else might be broken on it, if the oil lamp went on. The pump is going to be a new one but are there other possibilities of parts that you would check.

I am still a newbie on it and I don't want to be screwed by the guys in the shop. Everything has to be check now on it.

Give me some info and I will ask them if they have check those parts.

cheers.

martosh mv for ever
martosh79 is offline  
post #9 of 9 (permalink) Old 08-10-2010, 12:48 PM
lee
Senior Member
 
lee's Avatar
 
Join Date: Oct 2007
Location: As far away from mankind as I can get
Posts: 5,076
I would get the shop manuals for your bike and learn how to do all this simple stuff yourself. Alot of it is just common sense, patience and the intestinal fortitude to pick up a wrench and lay it to the bike.
lee is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome