I'm Sold! - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 08-30-2009, 08:13 PM Thread Starter
Senior Member
 
AF Agusta's Avatar
 
Join Date: Jan 2007
Location: Alexandria, VA
Posts: 361
I'm Sold!

Put in the new water pump and engine ice and went on a nice long ride today...I'M SOLD!!!! The 312 has never run cooler! When I used to spend 50% of the ride making sure I didn't overheat, the temperature gauge started to blink once, after sitting at a stop light for about 5 mins it bumped up and then as soon as I started moving again it went right back down. I COULD NOT BE HAPPIER! Highly encourage this for anyone with an F4.
AF Agusta is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 08-30-2009, 08:19 PM
Senior Member
 
Nicolino's Avatar
 
Join Date: Mar 2008
Posts: 1,434
sounds good but is this new factory upgrade (waterpump impeler) for all F4-1000 or just O7and up models ??? Anyone knows?
Nicolino is offline  
post #3 of 9 (permalink) Old 08-30-2009, 08:30 PM
lee
Senior Member
 
lee's Avatar
 
Join Date: Oct 2007
Location: As far away from mankind as I can get
Posts: 5,076
Excellent news! It fits all F4's I believe.

I got mine. Boy do I ever got mine.
lee is offline  
post #4 of 9 (permalink) Old 08-30-2009, 09:43 PM
Senior Member
 
Cash_Dawg's Avatar
 
Join Date: May 2009
Location: Sydney, Australia
Posts: 3,149
I have been told can be fitted to all F4's

_________________
A closed mouth gathers no feet.........
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cash_Dawg is offline  
post #5 of 9 (permalink) Old 08-31-2009, 05:42 AM
Senior Member
 
jomarti1's Avatar
 
Join Date: Mar 2008
Posts: 1,136
I was told it fits 07 1000R and up
jomarti1 is offline  
post #6 of 9 (permalink) Old 08-31-2009, 05:50 AM
Senior Member
 
jomarti1's Avatar
 
Join Date: Mar 2008
Posts: 1,136
Quote:
Originally Posted by AF Agusta View Post
Put in the new water pump and engine ice and went on a nice long ride today...I'M SOLD!!!! The 312 has never run cooler! When I used to spend 50% of the ride making sure I didn't overheat, the temperature gauge started to blink once, after sitting at a stop light for about 5 mins it bumped up and then as soon as I started moving again it went right back down. I COULD NOT BE HAPPIER! Highly encourage this for anyone with an F4.
I'm confused. Did your 312 went up and blinking after or before the new impeller?
jomarti1 is offline  
post #7 of 9 (permalink) Old 08-31-2009, 08:03 AM
Senior Member
 
Timster's Avatar
 
Join Date: Apr 2009
Location: Atlanta
Posts: 456
it fits all f4's

__

MV F4 1000 S Red/Silver
HUSABERG FS 570
Timster is offline  
post #8 of 9 (permalink) Old 08-31-2009, 09:01 AM
Senior Member
 
Stiv's Avatar
 
Join Date: Sep 2008
Posts: 307
Quote:
Originally Posted by AF Agusta View Post
the temperature gauge started to blink once, after sitting at a stop light.
Blinking? Is that alarm bells i can hear?

Nah seriously...... If you are ok with the bike reaching 112c with the dash blinking then all must ok .. yes?

Last edited by Stiv; 08-31-2009 at 09:07 AM.
Stiv is offline  
post #9 of 9 (permalink) Old 08-31-2009, 04:08 PM Thread Starter
Senior Member
 
AF Agusta's Avatar
 
Join Date: Jan 2007
Location: Alexandria, VA
Posts: 361
Quote:
Originally Posted by jomarti1 View Post
I'm confused. Did your 312 went up and blinking after or before the new impeller?
It went up beyond the "blinking" point constantly prior to the new impeller. Yesterday, it went up to that point once for a few seconds.
AF Agusta is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome