2001 F4 wiring/injector question - Page 3 - MVAgusta.net
 17Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 23 (permalink) Old 08-16-2019, 06:15 AM Thread Starter
Established Member
 
kevjayney's Avatar
 
Join Date: Oct 2007
Location: Scotland
Posts: 181
Quote:
Originally Posted by Robbedoes View Post
I am sorry for putting you in the wrong direction, i did that one time to check if all injectors were squirting (wide open throttle) but indeed you won't be able to see if the injection timing matches.
I do think you should verify if the injectors are wired correctly. You can pull all injector connectors (number them with tape) off, pull the ecu connector off (ECU pin 5 and 22 are the injectors pins, see manual). Get a multimeter set it to resistance (Ohm) or the buzzer function if it has it. Cyl 1+4 should be connected to pin 22. Cyl 2+3 should be connected to pin 5. And offcourse injector cyl 1 should be connected to cyl 4 and 2 to 3. (This is all based on the Brutale manual but it should be the same for an F4 with this ECU.)
Robbedoes,

Thanks very much for your input, I had a look through my manual but couldn't find much on this subject, so I took off the ECU plug and you were 100% correct about the leads.

Here are a couple of pics, I hope it explains this for anyone else that's not sure about their leads.

My findings are for F4 750 2001, so other models of that era might change.
Attached Images
  
esq'z me and Glenno like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Lang mae yer lums reek

2001 F4 750 1+1
2012 F3 675
kevjayney is offline  
Sponsored Links
Advertisement
 
post #22 of 23 (permalink) Old 08-17-2019, 02:12 AM
Established Member
 
Robbedoes's Avatar
 
Join Date: Apr 2016
Location: Netherlands
Posts: 100
New Site Garage
Quote:
Originally Posted by kevjayney View Post
Robbedoes,

Thanks very much for your input, I had a look through my manual but couldn't find much on this subject, so I took off the ECU plug and you were 100% correct about the leads.
Great! Glad you got it sorted. If ever needed you can also use this method to check the ignition coil wiring.
kevjayney likes this.

2003 MV Agusta Brutale 750S
Robbedoes is offline  
post #23 of 23 (permalink) Old 08-22-2019, 03:18 AM Thread Starter
Established Member
 
kevjayney's Avatar
 
Join Date: Oct 2007
Location: Scotland
Posts: 181
Right that's my injectors back from being serviced, fitted them and took the bike for a short run.

Findings are, idling is more smooth and probably give or take 100 rpm higher, which is the correct idling speed now.

There is still a flat spot low down but instead of from 3000rpm ish to 6000rpm its more like a dip at 3000-4500rpm (probably back to normal fuelling) clears its self after 4500rpm then takes off after 6000rpm.

I have sil moto exhausts so that will magnify any bad points in the mid range anyway.

The company I used was injectortune in the uk. I have no affiliation with this company I just picked them randomly off the internet. They cleaned the injectors and replaced the filters and o rings, with a printout of before and after graphs.

3 injectors were not passing the maximum amount of fuel.

Thanks for the tips and help on this from other forum members.
esq'z me, russell60 and Drewbert34 like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Lang mae yer lums reek

2001 F4 750 1+1
2012 F3 675
kevjayney is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome