puzzled... - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-27-2009, 04:20 AM Thread Starter
Senior Member
 
Tripleinside's Avatar
 
Join Date: May 2007
Location: Paris, FRANCE
Posts: 378
puzzled...

MY F4 1000S acts up, and I can't pin point the problem, so here it is.

- when it's really cold out, it will randomly have a hard time to start
- when it is warm, it will randomly lean miss in town
- it developped a very annoying habit of farting, well, more like a very loud BANG with flames coming out the exhaust in the following scenarios:

in any gear, you rev up to say 6000 rpm get off the throttle, let it get back down a bit, and the band occurs as soon as I touch the throttle and that the butterflies open a bit
It even does it when you rev, change up a gear and release the clutch lever= BANG
I noticed it starts to happen on any revs beyond 3000 RPM, below 3k it is OK
It never happens while descelerating, but on-throttle only

I have replaced, the EBS valve, EBS relay, full ignition (coils/leads), fuel pump, throttle bodies, checked the timing and valve clearance, tried different EPROM, with and without the catalyzer.
The bike is a 2005 F4 1000S, with 17000 kms.
It has an alarm, and HID.
CO=3.8%
throttle bodies setup as per the official MV manual

(PS: Brought it to an MV dealer who couldn't help.)

I'm running out of ideas, and this problem is annoying enough for me not to enjoy riding the bike anymore, so if someone has an idea before I sell the thing, thanx !

Last edited by Tripleinside; 06-27-2009 at 04:22 AM.
Tripleinside is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-27-2009, 08:06 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Did you run the bike on a dyno to see how it is fueling? Backfiring can be caused by either a lean condition or a rich condition.

Sounds like it happens when you up shift:

The engine is running rich and you have some unburnt fuel in the system which ignite in the hot exhaust causing flames to come out the back.

If it never happens when decelerating, I don't think it is running too lean.

I would run it on a dyno. It sounds like you have a rich spot somewhere.
CAG is offline  
post #3 of 6 (permalink) Old 06-27-2009, 09:50 AM
Senior Member
 
MikeF4Black's Avatar
 
Join Date: Mar 2008
Location: Amsterdam
Posts: 3,111
Cool

Quote:
tried different EPROM, with and without the catalyzer.
Erick, what's the exact set-up now, in which the problems you describe occur?

Nulla tenaci invia est via
MikeF4Black is offline  
post #4 of 6 (permalink) Old 06-27-2009, 10:01 AM Thread Starter
Senior Member
 
Tripleinside's Avatar
 
Join Date: May 2007
Location: Paris, FRANCE
Posts: 378
not been on a dyno, the bike should run fine with the OEM setup and OEM eprom

All I know is when I trim it really rich, the afterfire/backfire is way less present, which makes me think something is making it run lean.
I checked for intake leaks, but I couldn't find any
Tripleinside is offline  
post #5 of 6 (permalink) Old 06-27-2009, 10:07 AM Thread Starter
Senior Member
 
Tripleinside's Avatar
 
Join Date: May 2007
Location: Paris, FRANCE
Posts: 378
right now, normal exhaust, eprom, filter, N2 TB set to spec (1.5 turn out) the other TBs are balanced.
The trimmer is roughly half way its course, and at idle the gunson says there is 3.8% CO so within specs.
the cat is removed, but I tried it on, made no difference to the symptoms

only non OEM accessories are the HID light and alarm (Technoglobe TG2005)

Fuel range is 190 kms before reserve light comes on

I have a feeling it is linked to the shitty EBS injecting air all the time into N2 cyl, but I already replaced all the parts linked to the system
Tripleinside is offline  
post #6 of 6 (permalink) Old 06-27-2009, 09:06 PM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
Is there any chance you have a small leak at the EBS valve? That would cause a lean condition.

If you could get on a dyno, it will tell you if it is rich or lean and where. That would narrow the possibilities down a lot.
CAG is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome