Help.....Slipper clutch problems - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-22-2009, 07:50 AM Thread Starter
Established Member
 
Michel Canino's Avatar
 
Join Date: Jan 2006
Location: Dubai (U.A.E)
Posts: 198
Help.....Slipper clutch problems

I have fitted the slipper clutch on the F4 and I also have replaced the levers with the CRG ones.
On my last track day after 10 laps my clutch lever didn't work anymore, it became very soft and I couln't shift down any gear. I slow down and slowly the clutch start working again. I quite sure now and with the help of G. Rand that the clutch is properly fitted.
It looks like the clutch became very hot and when it cool down everything went back to normal.

My questions are:
- Do you think it's because I have to purge the hydraulic ?
- Do I have to fit back the original clutch lever ????
- Do I have to remove everything again ?????

I need your help guy's

Thanks

Michel
Michel Canino is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-22-2009, 10:02 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,695
Send a message via Skype™ to CAG
I would look closely at where the clutch lever engages engages the plunger of the master cylinder. If your new lever is not depressing the plunger the clutch won't engage (disengage?) and you won't be able to downshift.
CAG is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome