well my issues with MV continue - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 44 (permalink) Old 05-13-2014, 06:53 AM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
well my issues with MV continue

so after another 2 months of trying to work out what is wrong with my 2010 F4, after its already had a complete new engine put in it, still no one can tell me what the problem is.....

its flashing coil failure on the dash, yet the bike seems to run fine without missing etc.... other then when it decides to just randomly shut off!
have replaced all the coils, checked loose conections etc, MV have had it on the dyno and on the computer and still no one can tell me the problem
so now there solution is to just keep replacing parts untill they find the problem (at my cost btw)
cant believe 7 months after the engine blew and near killed me, MV still have not fixed the bike
hennessy is offline  
Sponsored Links
Advertisement
 
post #2 of 44 (permalink) Old 05-13-2014, 07:17 AM
Senior Member
 
gotojoe's Avatar
 
Join Date: Nov 2009
Location: Bellanagare, West Ireland 44 7875 299281
Posts: 9,933
It must be very frustrating for you...

I can't understand why they can't do a systematic check as per manual of the associated electrical components.

First reaction is to check with a multi-meter as per workshop manual the ( coil /ecu/fuel pump) relay and the associated fuse...



joe

Last edited by gotojoe; 05-13-2014 at 07:45 AM.
gotojoe is offline  
post #3 of 44 (permalink) Old 05-13-2014, 07:45 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Quote:
Originally Posted by gotojoe View Post
I tried to download the manual but its not playing ball this morning.

First reaction is to check with a multi-meter as per workshop manual the power relay and the associated fuse. On the 09s this is serving the coils and the ecu..

I'll try again later to get the manual off Donsy's site.

joe
Looks like I'm still struggling with some of the manuals being downloaded by some systems, try the y10-13 manual Joe, it's got everything in there also. I'll reload the y10 manual again. Please let me know when you pick up problems guys, I'm constantly busy on the site at the moment, and don't always get the chance to double check everything.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
Sponsored Links
Advertisement
 
post #4 of 44 (permalink) Old 05-13-2014, 08:11 AM
Senior Member
 
gotojoe's Avatar
 
Join Date: Nov 2009
Location: Bellanagare, West Ireland 44 7875 299281
Posts: 9,933
Quote:
Originally Posted by Donsy View Post
Looks like I'm still struggling with some of the manuals being downloaded by some systems, try the y10-13 manual Joe, it's got everything in there also. I'll reload the y10 manual again. Please let me know when you pick up problems guys, I'm constantly busy on the site at the moment, and don't always get the chance to double check everything.
I got it to work Donsy..and I down loaded it..

cheers

joe
gotojoe is offline  
post #5 of 44 (permalink) Old 05-13-2014, 08:46 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Thanks Joe

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #6 of 44 (permalink) Old 05-13-2014, 04:51 PM
Senior Member
 
Join Date: Dec 2012
Location: Devon, UK
Posts: 837
If you're getting spurious behaviour/shutdowns when the items in question are known to be working, I'd be looking at the ECU (or mebbe, at a stretch, the dash depending on what processing impact it has on the system). Is there someone who might be able to loan an ECU for you to try?
MV-Moose is offline  
post #7 of 44 (permalink) Old 05-13-2014, 05:30 PM
Senior Member
 
gotojoe's Avatar
 
Join Date: Nov 2009
Location: Bellanagare, West Ireland 44 7875 299281
Posts: 9,933
Quote:
Originally Posted by MV-Moose View Post
If you're getting spurious behaviour/shutdowns when the items in question are known to be working, I'd be looking at the ECU (or mebbe, at a stretch, the dash depending on what processing impact it has on the system). Is there someone who might be able to loan an ECU for you to try?
It is hard to diagnose at distance really but the ECUs don't often give trouble...There is a relay which serves the ECU and the Coils and the Fuel Pump.

I guess we could ask if the fuel pump is priming ?

Joe
gotojoe is offline  
post #8 of 44 (permalink) Old 05-13-2014, 06:25 PM
Senior Member
 
SpainF4's Avatar
 
Join Date: Jul 2011
Location: Benidorm
Posts: 860
Change all wiring .
http://pages.ebay.com/motors/link/?n...d=271484990478
http://pages.ebay.com/link/?nav=item...d=390531322810

www.mv-agusta.es using motorcycle app.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SpainF4 is offline  
post #9 of 44 (permalink) Old 05-14-2014, 12:18 AM
Senior Member
 
revhead1957's Avatar
 
Join Date: Apr 2011
Location: Brisbane, Australia
Posts: 1,610
Sensors changed on later model engines and not compatible with the earlier model ecu? Just chucking an idea out there....
As above are the circuit diagrams identical for all models?
revhead1957 is online now  
post #10 of 44 (permalink) Old 05-14-2014, 12:22 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
There's far too many differences Jon, in the sensors, the dash, the ECU and diagram.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome