2010 F4..shift light flashing red... warning? - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 03-08-2014, 08:47 AM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
2010 F4..shift light flashing red while riding... warning?

Just got my 2010 F4 back with a brand new motor, runs fine but the middle shift light blinks red, while riding.. is this some kind of warning or is the shift light shorting out or something... any one know whats going on?

Last edited by hennessy; 03-08-2014 at 10:07 PM.
hennessy is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 03-08-2014, 01:30 PM
Senior Member
 
Join Date: Jun 2006
Posts: 1,216
If it's doing that when you turn it off, isn't that just telling you the immobiliser is arming itself?

Si
TheCatWhisperer is offline  
post #3 of 17 (permalink) Old 03-08-2014, 10:06 PM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
its doing it while riding... but it does seem to be the same light as the immobiliser

the MV book says nothing about the shift lights doubling as any kind of warning light, so i figure i've some kind of short

after reading my original post i can see how that may have looked strange haha... the light coming on while riding, even at around 4000rpm
hennessy is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 03-09-2014, 12:52 AM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
after riding the bike again today, its a warning.... an error code, i cant see which one tho as it only flashes up on the screen every now and again for a split second.... i'm guessing after the engine swap its got a lose wire somewhere as its only flashing up, it doesnt stay there...

does anyone know where i can get a list of error codes etc ?
hennessy is offline  
post #5 of 17 (permalink) Old 03-11-2014, 04:30 PM
Established Member
 
Join Date: Nov 2013
Location: Southwest Michigan
Posts: 102
Glad to hear this all finally worked out for you now if you can get this issue corrected. Does anyone know if this issue is specific to a certain model year? Scary stuff really. How fast were you going when it let go?
Seismic is offline  
post #6 of 17 (permalink) Old 03-12-2014, 09:32 AM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
Well i found out that the light is infact a fualt code... trouble is we cant work out which. when the code comes up it should stay on the screen, and when u turn the bike off it will tell u what the code is, ie injector failure etc... trouble is on mine the code is only flashing up, doesnt stay there which is making it hard to find the problem... probably just a lose conection somewhere tho as the bike was just put back together
hennessy is offline  
post #7 of 17 (permalink) Old 03-12-2014, 09:37 AM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
Quote:
Originally Posted by Seismic View Post
Glad to hear this all finally worked out for you now if you can get this issue corrected. Does anyone know if this issue is specific to a certain model year? Scary stuff really. How fast were you going when it let go?

yes i'm glad it worked out, big thank u to MV Agusta for sorting everything out

no mention of this being an issue with the bikes in general... unfortunately failures can happen... i am just thankfull to have my bike back.... Well done MV
hennessy is offline  
post #8 of 17 (permalink) Old 03-12-2014, 09:39 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Good to see you're back up and riding again mate, hope you get this little issue sorted too.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #9 of 17 (permalink) Old 03-12-2014, 11:35 AM
Old Wing Nut
 
esq'z me's Avatar
 
Join Date: Aug 2007
Location: Marietta, GA
Posts: 18,429
Send a message via Skype™ to esq'z me
Shouldn't the ECU store past DTCs (detected trouble codes). The diagnostic software should be able to see what codes have been registered, even if they are not current.

I used to be fast....now I just dream about it.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'08 910R (Gina), '04 F4 SPR #275 Track Bike (Lola), YSR50 (The Rabbit), '71 CB100 (Lil' Red), '75 RD350C (Orange Bird) restoration project, '70 Suzuki F50 (Baby Blue)
esq'z me is offline  
post #10 of 17 (permalink) Old 03-13-2014, 08:10 AM Thread Starter
Established Member
 
hennessy's Avatar
 
Join Date: Jan 2013
Location: Australia
Posts: 179
yeah thats what i'm hoping, tho it means taking it to the local dealer who has been a real issue.... no choise tho i guess, hopfully he can help
hennessy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome