Motocorse Full TI Exhaust System - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 11-24-2015, 10:43 PM Thread Starter
New Member
 
Chris Jim's Avatar
 
Join Date: Jun 2014
Posts: 50
Motocorse Full TI Exhaust System

I'm sure this has not been discussed before, correct me if I'm wrong.
Does the existing ECU on the current model F4RR allow tuning of the Motocorse TI exhaust system.
Chris Jim is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 11-24-2015, 10:46 PM
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
There's two options for tuning, the Rexxar reflash, or the Rapid Bike piggyback system.
chwebby is offline  
post #3 of 15 (permalink) Old 11-24-2015, 11:07 PM Thread Starter
New Member
 
Chris Jim's Avatar
 
Join Date: Jun 2014
Posts: 50
Is that using the existing ECU or a new one completely ?
Chris Jim is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 11-25-2015, 12:13 AM
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
Both use the existing ECU. There is no standalone option for the 2013+ models.
chwebby is offline  
post #5 of 15 (permalink) Old 11-25-2015, 04:28 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
It has been discussed, but in the Performance section.
Race ECU does away with the O2 sensor, then Rexxer or Rapid Bike to tune, some still have problems if they don't get rid of the original ECU.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #6 of 15 (permalink) Old 11-25-2015, 07:15 AM
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
I must have missed that memo Dons. Thanks for clarifying.
chwebby is offline  
post #7 of 15 (permalink) Old 11-25-2015, 08:04 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 22,055
New Site Garage
Question

Quote:
Originally Posted by chwebby View Post
I must have missed that memo Dons.
Don't know what you're talking about, but it would be great if someone backed up their claims with some evidence instead.

I'm merely going on what local tuners have told me.

Be my guest and inform us about the removal of the O2 sensor ...etc.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is offline  
post #8 of 15 (permalink) Old 11-25-2015, 12:17 PM Thread Starter
New Member
 
Chris Jim's Avatar
 
Join Date: Jun 2014
Posts: 50
Thanks for the info, I will let you know how it turns out
Chris Jim is offline  
post #9 of 15 (permalink) Old 11-25-2015, 06:04 PM
Established Member
 
WFOF4Pilot's Avatar
 
Join Date: Apr 2014
Posts: 229
I have the Full Ti Bodis system and the stock ECU; the bike runs a little lean in the mid-range and will occasionally surge, on the track I don't notice anything - it runs fine. My brother tried the "piggy-back" on top of his ECU and had nothing but, issues. He finally ended up sending it back and is now running the stock ECU w/ a full Bodis and his bike (2012 F4R) seems to run just fine. -Davis
WFOF4Pilot is offline  
post #10 of 15 (permalink) Old 11-26-2015, 09:08 AM
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
Quote:
Originally Posted by Donsy View Post
Don't know what you're talking about, but it would be great if someone backed up their claims with some evidence instead.

I'm merely going on what local tuners have told me.

Be my guest and inform us about the removal of the O2 sensor ...etc.
Wasn't being a smart ass Dons. I actually wasn't aware people were having problems without the race ECU, that's good to know.
chwebby is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome