Bodis Header - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 05-30-2015, 09:28 AM Thread Starter
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
Bodis Header

Does anybody have pictures of the header pipes installed on a +2010? I can't seem to figure out how this is supposed to work.
chwebby is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 05-30-2015, 10:47 AM
Established Member
 
Join Date: Jul 2013
Posts: 78
My bike is still being tuned but this is the only pic I have. They sent this after the dyno runs. Not sure if it helps.
Attached Images
 
CAZCADE is offline  
post #3 of 26 (permalink) Old 05-30-2015, 11:03 AM Thread Starter
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
As awesome as that picture is, it doesn't help. I'm stumped on how the header pipes actually attach to the engine and the order the brackets are put on the stud. The only way I can get it to work is to put the header pipes in, put the Bodis bracket holding the pipes together on, then flip the oem "cross" bracket around from the way it came off. This seems so wrong but it's the only way the pipes seem to sit right.
chwebby is offline  
Sponsored Links
Advertisement
 
post #4 of 26 (permalink) Old 05-30-2015, 02:28 PM Thread Starter
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
I might see the issue. Are the bodis brackets supposed to have a bend or be straight?
chwebby is offline  
post #5 of 26 (permalink) Old 05-31-2015, 12:51 PM
Established Member
 
Join Date: Jul 2013
Posts: 78
Man, I can't believe no one has helped you. You should message spainf4 or look up his threads. He went into detail installing bodis headers and slipon. With pics.
CAZCADE is offline  
post #6 of 26 (permalink) Old 05-31-2015, 01:54 PM
Senior Member
 
Join Date: Feb 2015
Posts: 314
I have good pictures for installing the slipon and removing the flap cables but I have not installed the headers yet.

2014 F4 RR
Ducati Monster M1000S
retrodrive is offline  
post #7 of 26 (permalink) Old 05-31-2015, 02:01 PM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 21,010
Send a message via Skype™ to silentservice703
Does this help?

Name:  bodis.jpg
Views: 276
Size:  82.3 KB

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
post #8 of 26 (permalink) Old 06-01-2015, 02:29 PM Thread Starter
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
I'm pretty sure I've figured it out. The OEM cross bracket is not used with the bodis headers at all, the plates/brackets attached to the header pipe ends were bent from over tightening, and the spacers needed weren't included. I've bent the plates back as best I could, and used a slightly larger nut as a spacer on the stud. I also had to take the slip on end to the shop and have the gasket end expanded out as that end was also over tightened from the previous owner and couldn't get the gasket to fit. Everything will get tightened up tonight, radiator and tank put back on, and fingers crossed there's no leaks.
chwebby is offline  
post #9 of 26 (permalink) Old 06-01-2015, 02:30 PM Thread Starter
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
Thanks for the help guys. SpainF4's thread helped a lot. All the searches I did and his never popped up for me until I just searched his username.
chwebby is offline  
post #10 of 26 (permalink) Old 06-15-2015, 12:38 PM Thread Starter
Senior Member
 
chwebby's Avatar
 
Join Date: Dec 2012
Location: Saskatchewan, Canada
Posts: 301
So attempt one, headers leaked like crazy. The Bodis brackets were bent so bad that they couldn't push in flush on the pipes. So pulled it all off again and realized the ends actually can pull off the pipe (duh), allowing you to remove the bracket. Just flipped the brackets around, tightened until they bent back and sat flush, and it all seems to work now
chwebby is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome