2015 MV F4 - Fault Injector Blow error - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-15-2015, 09:35 PM Thread Starter
New Member
 
Join Date: May 2015
Location: VA
Posts: 5
2015 MV F4 - Fault Injector Blow error

I'm new to MV, my first one. Only been on 3 times, but already have to take it back to the shop. The error was STOP. FAULT. Injector Blow. Wouldn't/won't start up. Found a leak/smudge by the gear shifter. Has anyone had this issue before? If so, what was the fix? Parts needed? Attached a couple of pics.
Attached Images
  

New2mv owner

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New2mv is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-15-2015, 11:05 PM
Senior Member
 
flyboyk's Avatar
 
Join Date: Mar 2009
Posts: 445
It`s INJECTOR 3 LOW fault. Take it to dealer

2014 MV Agusta F4
Moto Guzzi 1100 Sporti
Yamaha R1
Honda CT90
flyboyk is offline  
post #3 of 8 (permalink) Old 05-15-2015, 11:35 PM Thread Starter
New Member
 
Join Date: May 2015
Location: VA
Posts: 5
OK cool. Thanks flyboyk.
New2mv is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 05-16-2015, 12:49 AM
Senior Member
 
Fragile's Avatar
 
Join Date: Feb 2014
Posts: 661
New Site Garage
Dam that sucks. Have them give u new one. I bought a VW Cabrio once. It had stuck fuel gauge several days later. Brought to dealer to repair. Sales saw me and swiftly gave me another brand new on from the lot and updated all my paper work. Talk about integrity selling new, it should act like new!
Fragile is offline  
post #5 of 8 (permalink) Old 05-16-2015, 04:48 AM
New Member
 
Paors's Avatar
 
Join Date: Apr 2013
Location: Vancouver, BC
Posts: 62
Send a message via Skype™ to Paors
Does it say just "Injector 3 low", or does it cycle between other errors? I had the same message among others when the fuel pump fuse was blown

'13 F4 RR
'11 BMW R1200RT
'12 Aprilia Dorsoduro 1200 - sold
'08 BMW R1200GS Adv - sold
'10 HD XR1200 - sold
'10 Blata Ultima
Paors is offline  
post #6 of 8 (permalink) Old 05-16-2015, 07:37 PM Thread Starter
New Member
 
Join Date: May 2015
Location: VA
Posts: 5
@Fragile and Paors. Yes, only injector 3 low, no other errors come up. I took it to the shop today. They are ordering a new fuel injector. They said everything was connected fine and no blown fuses, but that the hydraulic system kept it open and it put a "choke-hold" on the engine which is why it wouldn't start. They were finally able to clear the code by messing with the wires and was able to get it to start up, but didn't want to give the OK on it and then it happen again. So they will order a new part and do an oil change to make sure everything is I hope to have it back in the next week or two.

New2mv owner

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New2mv is offline  
post #7 of 8 (permalink) Old 07-17-2015, 02:52 PM Thread Starter
New Member
 
Join Date: May 2015
Location: VA
Posts: 5
Issue ended up being a bad ECU. They replaced it and bike is back working.

New2mv owner

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New2mv is offline  
post #8 of 8 (permalink) Old 07-18-2015, 09:11 AM
Senior Member
 
silentservice703's Avatar
 
Join Date: Feb 2008
Location: Duxbury, MA, USA
Posts: 20,994
Send a message via Skype™ to silentservice703
Thanks for keeping The Comunity informed!

Gapalicious 2019 at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
from OCTOBER 2-6, 2019

Call (423) 519-2000 or (423) 253-6213 to reserve your Riverfront Cabin. PM me for The Crow's Nest reservation!!!

Email/Paypal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My personal Cell Phone: (781) 223-3020


'07 F4 312R, '10 B4 1090RR, '15 B3 800RR
'07 Ducati Monster S4Rs, '07 Ducati Monster 695
2010 Harley Davidson Ultra-Classic Electra-glide CVO FLHTCUSEBLK
'63 Honda C100A Cub
'61 MVA TRA 125
silentservice703 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome