Need help with Indicators - MVAgusta.net
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-14-2012, 08:42 PM Thread Starter
New Member
 
F4RUSTY's Avatar
 
Join Date: Jun 2011
Posts: 26
Thanks: 0
Need help with Indicators

Hi guys, i have a problem with the indicators on my 05 F4 1000S. When i turn them on they flash up to 15 times then they just stay lit up, if i turn them off & back on straight away they still stay lit up but if i leave them off for a bit they work for 15 or so more flashes. The front are standard and the rear are LED. When i got the bike i was told it had a LED controller, but i am unsure what or where this is. If anyone has any ideas i would appreciate the advise. Thank you Russell.
F4RUSTY is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-16-2012, 09:43 AM
Established Member
 
Join Date: Dec 2010
Location: Perth, W.Aust
Posts: 137
Thanks: 0
im assuming that all the bulbs stay lit and not just one side? but under the left hand fairing there is a group of 3 relays.....the middle one is the flasher relay. i would start there.

i had this problem on my f4 750. replaced that unit and everything wne tback to normal.
token is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome