is possible that the bike will not start because of the SPU? - MVAgusta.net
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-01-2012, 02:33 PM Thread Starter
New Member
 
Join Date: May 2012
Location: italy
Posts: 24
Send a message via Yahoo to mv freac
is possible that the bike will not start because of the SPU?

is well known that SPU can make a lot of problems,may be the epic fault on the MV Agusta. but how many of you may say that this problem resulted in inability to start the bike?And, if possible, give details.I would say that 60% of us have had a problem with the SPU.that makes us rush when we have a problem, and blame SPU!How serious is it? if you havea story , please write here, it may save lot of headache.Thank you
mv freac is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-01-2012, 06:15 PM
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 1,806
New Site Garage
Hi, review this one.

Service Power Unit (SPU) - Resolve

In direct answer to your question, "yes, it is possible", but very unusual. Yes, there is often a willingness to quickly jump to the SPU as the cause of the problem. I believe CAG (like Mitchy) did the right thing by starting a thread specific to failures - this provides far more direct evidence.

Cheers

In the Garage today...
'14 H-D Street Glide Rushmore
'11 MV Agusta Brutale 990R Special Edition #81/150
cruiser is offline  
post #3 of 11 (permalink) Old 07-04-2012, 02:54 PM
New Member
 
Join Date: Jul 2012
Posts: 2
My 2005 750S is also dead. Died suddenly on highway yesterday, won't start since. No sputtering, etc. just died. Battery turns it over fine, won't fire up.

Bike has 2300 miles and in great shape otherwise.

Disapponting to say the least.
badengineer is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 07-04-2012, 05:27 PM
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 1,806
New Site Garage
make sure you check all those fuses first - if there are no other electrical gremlins being displayed it may be a simple resolve.

In the Garage today...
'14 H-D Street Glide Rushmore
'11 MV Agusta Brutale 990R Special Edition #81/150
cruiser is offline  
post #5 of 11 (permalink) Old 07-05-2012, 01:27 AM
Senior Member
 
Join Date: Jun 2007
Location: Calga, NSW
Posts: 1,132
Quote:
Originally Posted by mv freac View Post
is well known that SPU can make a lot of problems,may be the epic fault on the MV Agusta. but how many of you may say that this problem resulted in inability to start the bike?And, if possible, give details.I would say that 60% of us have had a problem with the SPU.that makes us rush when we have a problem, and blame SPU!How serious is it? if you havea story , please write here, it may save lot of headache.Thank you
Yes it is. My first spu failure was riding home from work one day, complete loss of power. Lights etc on, but engine no go.... Pulled over, turned ignition key off, back on, started it up and rode a little further before it died again. It would turn over but would not fire up and run.
rsawkins is offline  
post #6 of 11 (permalink) Old 07-05-2012, 06:43 PM Thread Starter
New Member
 
Join Date: May 2012
Location: italy
Posts: 24
Send a message via Yahoo to mv freac
mv freac is offline  
post #7 of 11 (permalink) Old 08-21-2012, 10:13 PM
New Member
 
gpcarrera's Avatar
 
Join Date: May 2012
Posts: 15
My 750 died on freeway today. Dash lights up..engine attempts to turn over but will not start.
Fuses on right side near fram all seemed fine.
gpcarrera is offline  
post #8 of 11 (permalink) Old 08-22-2012, 06:45 AM
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Dec 2006
Location: Home. In Dixie.
Posts: 13,685
Send a message via Skype™ to CAG
Quote:
Originally Posted by gpcarrera View Post
My 750 died on freeway today. Dash lights up..engine attempts to turn over but will not start.
Fuses on right side near fram all seemed fine.
Damn, this is confusing. How many problems in the same thread?

Those of you posting that your bikes "died on the freeway or died while riding" need to look into the gas tank. It is also common for the fuel hose inside the tank to pop off or rot from the ethanol in the gas.

If you see bubbles, that's your problem. When the bike is running fine, dies, and turns over but won't catch, it's almost always a fuel delivery problem and not an ignition problem.
CAG is offline  
post #9 of 11 (permalink) Old 08-22-2012, 03:40 PM
Senior Member
 
cruiser's Avatar
 
Join Date: Jun 2007
Location: Auckland, New Zealand
Posts: 1,806
New Site Garage
Quote:
Originally Posted by CAG View Post
Damn, this is confusing. How many problems in the same thread?

Those of you posting that your bikes "died on the freeway or died while riding" need to look into the gas tank. It is also common for the fuel hose inside the tank to pop off or rot from the ethanol in the gas.

If you see bubbles, that's your problem. When the bike is running fine, dies, and turns over but won't catch, it's almost always a fuel delivery problem and not an ignition problem.
+ 1 CAG

In the Garage today...
'14 H-D Street Glide Rushmore
'11 MV Agusta Brutale 990R Special Edition #81/150
cruiser is offline  
post #10 of 11 (permalink) Old 08-23-2012, 01:45 AM
Moderator
 
Donsy's Avatar
 
Join Date: Aug 2008
Location: Australia
Posts: 21,862
New Site Garage
What they said........and

Quote:
Originally Posted by gpcarrera View Post
My 750 died on freeway today. Dash lights up..engine attempts to turn over but will not start.
Fuses on right side near fram all seemed fine.
Why don't you start a new thread matey, or at least go to the F4 section never mind the Maintenance section.

PS. Welcome to the forum.

Dons Nel
Own - Two F4 1000R's 06 and 07.
PayPal :
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

eMial:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mobile in Australia: 0438 385 776
Website with MV Manuals for Most models -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Donsy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to use all of the features of the MVAgusta.net site, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome